0

Couldn't find this anywhere, so hoping for some assistance here.

I'm doing my master thesis and I as an example I need to reference a lot of information from European Space Agency website.

I'm using overleaf, the tufte book style and a reference in the references.bib could look like this.

@misc{sent2radio,
  author = {ESA - Sentinel Online},
  title = {{Sentinel-2} Radoiometric Resolutions},
  year = 2019,
  url = {\url{https://sentinel.esa.int/web/sentinel/user-guides/sentinel-2-msi/resolutions/radiometric}},
  urldate = {2019-14-01}
}

When I cite that, it is perfectly added to the page and the bottom reference list. The URL is not displayed anywhere, as is common. However, my supervisor has requested that they are able to click the reference in the end of my document, when it turns into a PDF file. So they can check references by going straight to the link. See the image I have attached. Those references I framed in blue, all have individual URL's attached to them and should be directly clickable.

I hope my question is clear enough. Thanks for your time.

enter image description here

  • 2
    (1) welcome, (2) As always on this site, please provide a full but minimal example instead of sniplets others cannot test without making a lot of guesses. With bibtex it is important to know which style you are using, again information you do not provide. – daleif Jan 25 at 12:04
  • if biblatex is an option for you, see tex.stackexchange.com/a/207028/36296 – user36296 Jan 25 at 12:08
  • Thank you for the answer. The code is massive already and contains several additional files. Thats why I did find it a good solution to share it ;) I'll look into the link you provided. Thanks =) – Mars Jan 25 at 12:34
  • If you are using biblatex then url = {\url{https://sentinel.esa.int/web/sentinel/user-guides/sentinel-2-msi/resolutions/radiometric}}, is wrong, if you are using a BibTeX style it is almost certainly wrong. The url field usually contains only the URL in verbatim, no escaping or formatting is applied and no \url wrapper is needed. Try url = {https://sentinel.esa.int/web/sentinel/user-guides/sentinel-2-msi/resolutions/radiometric}, instead. – moewe Jan 25 at 12:57
  • See also tex.stackexchange.com/q/471424/35864 – moewe Jan 25 at 12:58
1

I found a sort of different solution to this. Since the tufte book style has a very large definition file over ruling everything, it can be tedious to move around its code if you are as inexperienced as I in this. However by doing this little trick as shown below, I can make the title clickable - even if it is a bit messy. Its a win, I'll take it.

@misc{sent2radio,
  author = {ESA - Sentinel Online},
  title = {\href{https://sentinel.esa.int/web/sentinel/user-guides/sentinel-2-msi/resolutions/radiometric}{Sentinel-2 Radiometric Resolutions}},
  year = 2019,
  url = {\url{https://sentinel.esa.int/web/sentinel/user-guides/sentinel-2-msi/resolutions/radiometric}},
  urldate = {2019-14-01}
}

It completely ignores the url line. But by adding a href to the title. That part is now a clicky!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.