1

Although the question of getting the correct .bbl version for arXiv has been asked and answered before, I've had trouble implementing some of the suggested solutions on the Mac, so please read to the end.

Problem: arXiv wants a certain version of .bbl format (currently 2.8) and that doesn't match the version produced by my computer's TeXLive. Here are some attempted solutions.

(1) I downloaded and installed the 2016, 2017, and 2018 MacTex distributions. The arXiv compatibility requires biblatex 3.5, 3.6, or 3.7. However, the MacTex distributions from 2016 and 2017 (the historical versions available now) use 3.3, and the MacTex distribution from 2018 uses 3.8. (I know this because when it runs in TeXShop, it tells me what the version is.)

(2) I downloaded the biblatex 3.5 version and tried to install them into my TeXLive 2016 distribution. When I try to uninstall the other biblatex (either by command line or the TeXLive Utility GUI), the tlmgr refuses to do this, and says it's not allowed because other packages depend on biblatex. So I tried uninstalling the other packages too, and there was a similar error message. How can I get the tlmgr to allow me to manually change the version?

(3) I was hoping that the default / PC distribution of TeXLive 2016 had the right version of biblatex. So I tried to point my TeXLive Utility at the historical repository or other places that store the biblatex 3.5 code, but it won't connect because it says it can't verify that the repository has the correct version. Can I override it?

(4) I've heard that you can add packages such as biblatex by dragging them to the right folder in the texmf folder. I don't know the exact location to do this on a Mac with multiple versions of TeXLive added, and whether / how to get rid of the previous version of biblatex and install the desired version. Indeed, the only versions of installed packages I see in the 2016 folder are the texbin files in an executable or other precompiled format rather than the source code, so I'm not sure how to replace them manually.

(5) Actually, last November, I uploaded a paper with .bbl generated using TeXLive 2015, and it worked just fine. This time, I tried the 2015 version and it did not work. Since arXiv has not updated their TeXLive since then, I don't know why it doesn't work now. Maybe the compatibility issues didn't come up in .bbl file for the other bibliography for some reason?

I'm not too experienced with command line programming, though I know in theory how it should work, so I was hoping for an easy fix that would allow my biblatex to produce the right format. I realize there are alternative solutions (e.g. upload the bibtex source code to arXiv with your paper), and ultimately I ended up rewriting the bibliography by hand. But I'll run into this problem again in the future, and I suppose other MacTeX users may run into it, possibly even with later editions in future years.

  • 1
    I don't own a Mac, so I can't double-check what you say, but I find it quite weird that both the 2016 and 2017 versions should ship biblatex 3.3. biblatex 3.7 came out 2016-12-08 and should have had plenty of time to make it into MacTeX 2017 (on release of MacTeX 2017). [For people coming here via Google, github.com/plk/biblatex/wiki/biblatex-and-the-arXiv has a write-up of the issues that one might face with biblatex and arXiv.] – moewe Jan 27 at 15:33
  • To point (2): If tlmgr does not let you uninstall biblatex you could manually remove the filed and manually install the downloaded version. But of course that its absolutely not recommended as it might cause a number of version issues both with biblatex and packages that rely on biblatex. You certainly need to get the correct Biber version as well. If you do this at all, you should do this only on a "secondary" TeX system, not your main TeX installation (MacTeX allows you to manage several TeX systems on one machine, or so I've heard). – moewe Jan 27 at 15:39
  • Ad point (5): Yes the .bbl issue is only a pain for biblatex bibliographies. The .bbl files produced for BibTeX bibliographies don't have the same version dependencies that biblatex has. – moewe Jan 27 at 15:40
  • I’m curious, does arXiv really use biblatex? – Herb Schulz Jan 27 at 20:45
  • 2
    @HerbSchulz The arXiv uses neither biblatex, nor Biber, nor BibTeX. They just compile with LaTeX and bibliographies have to be provided with pre-compiled .bbl files that are uploaded together with the .tex file. For BibTeX-based bibliographies that is no issue, but for biblatex once can get into version trouble if the .bbl was not generated with a Biber-version compatible with the biblatex version that the arXiv has installed. – moewe Jan 27 at 21:01
1

ArXiv's behavior of not accepting (reproducible) .bib is increasingly annoying in this regard. I also had this problem and a previous workaround for me was to compile the .tex (and then to get the .bbl from the .aux) on a different machine which produced output with biblatex bbl format version 2.8. As this machine was updated, I had to look into installing a texlive version which provides 2.8. My local MacTeX 2018 version comes with 2.9 which failed. I installed MacTeX 2016 from here but that provided 2.7 which also failed (one needs precisely 2.8). I then installed MacTeX 2017 (same link) and this indeed provided 2.8. So I can reproduce a lot of what the OP said, but not that the 2017 version doesn't work (it worked for me under macOS 10.14.3 with MacTeX 2017).

Note:

1) Related posts are this and this.

2) You can switch between the versions via Applications -> TeX -> TeX Live Utility -> Configure -> Change Default TeX Live Version...

3) 2) only works in versions 2017 and 2018 (order of installation does not matter, but it did not work when installing the 2016 version after the 2018 version).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.