7

I'm running TexShop 4.3 on OSX 10.14.1. The key combination ⌘+ would increase the font size in my editor but it hasn't been working in the last few releases. I also tried ⌘<shift>+ but that doesn't help either. In TexShop's menu under Source -> Font -> Bigger has the symbol ⌘= next to it. Anyone know the right keystrokes to increase/decrease font size in the editor?

1
  • 1
    You have to select the text and then increase the size Jan 26 '19 at 22:26
9

I'd say this is a “hidden feature”. In version 4.23 the behavior is the same: when pressing =, nothing happens unless the first character in the document is selected (with any number of following characters). The same for - for decreasing the font size.

Similarly, if the focus is on the editing window and you press K, doing a choice in the font window that appears has no effect, unless the first character is selected.

This font setting is not permanent and will be lost when closing the window.

3
  • 1
    This is bad news, I'm deprecating TeXShop and choosing an older version to avoid this. Aug 19 '19 at 19:52
  • "Hidden"?! I see no reason to hide this feature. Does anyone have any context on this?
    – k-dubs
    May 19 '20 at 5:09
  • 1
    @k-dubs That was understatement for “bug”.
    – egreg
    May 19 '20 at 8:11
5

Changing the source font size permanently is possible if you follow the answer I got by Richard Koch. Here it is:

Go to TeXShop Preferences, and under the Source tab the first item is Document Font. Push the "Set" button. Two things happen. A Small window comes up showing you some sample text, and the font panel comes up. DO NOT CLICK OK in the sample yet.

Using the font panel, select the font and size you like. The sample will change, showing the new results. When you are happy, click OK in the sample. And then, click OK at the bottom of the preference dialog.

1
  • 1
    Re Volker's explanation: I wonder how the "font panel" comes up. Nothing happens for me in TeXShop but the Sample text panel covers the whole Source panel (almost) and I cannot change the editor font at all.
    – uhligfd
    Aug 31 '19 at 19:01
2

(I am using TeXShop in a brand new MacTeX 2020 installation and felt the answers here were not clear, so I decided to post a new answer.)

Open TeXShop. Go to TeXShop--->Preferences--->Source. Under Document Font, click Set.... A box called Sample Text and a box called Fonts appear. You need to delete all the text in the Sample Text box first. Then select the font you want in the Font box. Now type some text in the now empty Sample Text box (empty because you just deleted the text). Click OK in the Sample Text box. Then click OK again to close the menu.

1
  • 1
    Welcome to TeX.SE! Can you add please some screenshots of your used menu points to your answer?
    – Mensch
    May 9 '20 at 17:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.