0

When I want to print integral symbols such as \oiint using the esint package, the integral signs look ugly: enter image description here

MWE:

\documentclass{article}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{esint}
\begin{document}
\begin{equation}
\displaystyle\oiint_{\partial R} F\cdot n d\sigma=\iiint_R \mathrm{div} Fd\tau
\end{equation}
\end{document}

I am aware that this question has been asked earlier here (Getting a proper \oiint symbol (not bitmap)), but the person who asked this question uses TeX Live and Mac.

How can I solve this? I am using MikTeX 2.9 and Windows 10. I hope you can tell me how to solve this without redefining all sorts of commands or loading many other packages. I read that some parts of the package may not be (fully) installed - how should I install them?

Any help is appreciated. Thanks in advance.

  • Welcome to TeX.SE. Is the esint-type1 installed on your system? If not, can you use the MikTeX Package Manager (MPM) utility to install the package? – Mico Feb 2 at 10:50
  • Yes, I think so. When I search in my MPM, I find a package with the name esint, and with the title esint10 in Type 1 format. – efreeeze Feb 2 at 11:13
  • 1
    It works fine for me in miktex. If you have the font installed then probably the map file is not up-to-date. Run in the miktex console, user mode, the task "refresh font map files". – Ulrike Fischer Feb 2 at 11:26
1

Run in the miktex console, user mode, the task "refresh font map files".

That definitely was good advice! I will post here how I solved the problem.

For some reason, I did not have a MikTeX console on my computer, only MPM, MikTeX Update and MikTeX Settings. In one of those (I don't know which one anymore), I could update the package database, which I did. This solved the problem.

However, after I had done that, Windows couldn't find any of the three aforementioned MikTeX programs. I do not know the reason for this. I have been fiddling around a bit, and now Windows starts the MikTeX console whenever I start any of these three programs. It hasn't created any problems so far.

Thank you all very much for helping me!

Edit: to get rid of the dead links and to make sure I have the most recent version, I decided to reinstall MikTeX (a bit overkill :)). The same error with the ugly integral sign occurred again, here's more precisely how I fixed it. I ran the MikTeX console as an administrator (but I think user works as well). Then, under "taks" on the toolbar, I clicked "update package data base". That did the trick.

  • 1
    miktex has removed the old three configuration tools and replaced them by the miktex console. It is quite possible that the change leaves some dead links in the windows menus, simply remove them. – Ulrike Fischer Feb 2 at 13:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.