0

I am struggling to submit my work on Arxiv. Even though referencing citations works, referencing to the equations within my tex file does not work. It results in (??).

I checked all the Arxiv help page suggestions, nothing helps.

I just use

\begin{align}\label{aa}
\begin{array}{lll}
\text{anything here}
\end{array}
\end{align}

and the result is still the same.

I import \documentclass[]{interact} which is the LaTeX temple of Taylor & Francis, given here.

The errors I have from Arxiv is available here.

I would appreciate any help and idea.

  • 1
    Reading the .log file, it is very eminent that LaTeX fails to find the graphics file Turnover_costs_over_time' and stops compilation very early (at line 360+x) and as such there is no change to write the label information, so no wonder \ref{aa} results in ?? You seem to have an outdated TL distribution (TL 2016) as well... we're heading towards TL 2019 in a few months... – user31729 Feb 3 at 19:00
  • Thank you for your answer! However, I don't think it is due to the turnover costs image. Because, my file is being compiled and the final PDF is just what I have on my local Tex platform. The only issue is that the equations are referred as ?? – independentvariable Feb 3 at 19:23
  • You should explain then, why LaTeX reports the missing file and performs an emergency stop on compilation ;-) – user31729 Feb 3 at 21:08
  • I added `.png' at the end. Now I don't get that warning but still have the ?? equation reference :( – independentvariable Feb 3 at 21:30
  • 1
    Have you tried any other "classic" document class like article or memoir to find the source of the problem? Have you tried to turn off arxiv's hypertex through 00README.XXX file? – Leonid Feb 5 at 7:44
1

Quoting https://arxiv.org/help/faq/mistakes#nohypertex:

By default, our TeX system uses HyperTeX to add hyperlinks between references, sections and equations within your paper. These show up in the PDF (and in the PostScript with some viewers).

HyperTeX conflicts with a few style and class files. If you think this is a problem, you can disable HyperTeX for your submission by including a file 00README.XXX. It should contain the line:

nohypertex

Note that HyperTeX changes the way citations appear in some styles — ranges will be represented as [11, 12, 13] instead of [11–13]. This is necessary for HyperTeX to be able to make individual links to each citation.

More information about 00README.XXX available at https://arxiv.org/help/00README. Just a little quote from it:

The 00README.XXX file is read line-by-line before files are processed by AutoTeX. The order of lines is unimportant.

nohypertex

This stops any attempt by arXiv to automatically augment a paper with hyperlinks. However, it does not affect any facilities explicitly used within the paper's source.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.