0

I want to cite a corporation as an "author" in my references. However, there is always a point between the "author" and the "year" in the references. Normally this makes sense, as the typical author has a given name and the point serves to abbreviate the name. E.g., "Miller, T." for Tom Miller.

For a corporation, that does not make sense. How can I delete the point? It looks like this: "Corporation. (2019)." I want to have it like this: "Corporation (2019)." I am using biblatex (with biber) and my style is APA.

\documentclass[12pt, titlepage, openright]{report}

\usepackage[american]{babel}
\usepackage{csquotes}
\usepackage[style=apa,backend=biber,natbib=true,uniquename=false]{biblatex}
\DeclareLanguageMapping{american}{american-apa}

.bib entry

@Book{BMW_2012,
  title  = {{BMW i Ventures investiert in preisgekröntes Mobility-App Unternehmen Embark}},
  year   = {2012},
  author = {BMW}},
  note   = {Retrieved from https://www.press.bmwgroup.com/deutschland/article/ \\ detail/T0134380DE/},
2
  • 3
    Welcome. You will need to provide information about what system (bibtex, biblatex) and style you use. But TBH this is probably rather tricky, and will I think require biblatex and possibly some rather ad hoc adjustments. Why do you want this? If the Corporation is the author, isn't it right to punctuate it thus? Commented Feb 4, 2019 at 19:14
  • Could you post a minimal code illustrating the probelem. We do not even know which entry type is used.
    – Bernard
    Commented Feb 4, 2019 at 19:41

2 Answers 2

4

According to https://blog.apastyle.org/apastyle/2011/09/group-authors.html the period after a corporate author is actually correct behaviour

American Psychological Association. (n.d.). About APA. Retrieved from http://www.apa.org/about/

Notice that the author portion still ends with a period.

There are also a few examples that show this behaviour in the biblatex-apa example document, in particular 7.03:31, 7.10:72, 7.02:28, 7.08:54, 7.03:35, 7.03:32 (if I'm not mistaken at least some of those entries are real example from the respective sections of the APA manual, in case you want to double-check).


If you still want to go against APA style and want to suppress the period (I strongly advise against that), then I can offer the following solution where you have to manually set an option in the .bib entry.

\documentclass[american]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[style=apa, backend=biber]{biblatex}

\newtoggle{bbxapa@suppressauthoryearperiod}
\DeclareEntryOption[boolean]{suppressauthoryearperiod}[true]{%
  \settoggle{bbxapa@suppressauthoryearperiod}{#1}}

\renewbibmacro*{author}{%
  \ifnameundef{author}
    {\usebibmacro{labeltitle}}
    {\printnames[apaauthor][-\value{listtotal}]{author}%
     \setunit*{\addspace}%
     \printfield{nameaddon}%
     \ifnameundef{with}
       {}
       {\setunit{}\addspace\mkbibparens{\printtext{\bibstring{with}\addspace}%
        \printnames[apaauthor][-\value{listtotal}]{with}}
        \setunit*{\addspace}}}%
  \iftoggle{bbxapa@suppressauthoryearperiod}
    {\setunit{\addspace}}
    {\newunit}%
  \newblock%
  \usebibmacro{labelyear+extradate}}

\renewbibmacro*{editorinauthpos}{%
    \global\booltrue{bbx:editorinauthpos}%
    \printnames[apaauthor][-\value{listtotal}]{editor}%
    \setunit{\addspace}%
    \ifnameundef{editor}
      {}
      {\printtext[parens]{\usebibmacro{apaeditorstrg}{editor}}%
       % need to clear editor so we don't get an "In" clause later
       % But we also need to set a flag to say we did this so we
       % don't lose sight of the fact we once had an editor for
       % various year placement tests
       \clearname{editor}%
       \iftoggle{bbxapa@suppressauthoryearperiod}
         {\setunit{\addspace}}
         {\setunit{\adddot\addspace}}%
       \usebibmacro{labelyear+extradate}%
       \setunit{\adddot\addspace}}}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@Book{BMW_2012,
  title  = {BMW i Ventures investiert in preisgekröntes Mobility-App Unternehmen Embark},
  year   = {2012},
  author = {{BMW}},
  url    = {https://www.press.bmwgroup.com/deutschland/article/detail/T0134380DE/},
  langid = {ngerman},
  options = {suppressauthoryearperiod},
}
\end{filecontents}

\addbibresource{\jobname.bib}


\begin{document}
\cite{BMW_2012}
\printbibliography
\end{document}

BMW (2012). BMW i Ventures investiert in preisgekröntes Mobility-App Unternehmen Embark. Retrieved from https://www.press.bmwgroup.com/deutschland/article/detail/T0134380DE/

I did not want to add an 'automatic' solution because there is no way to tell a corporate author like "BMW" from a person with only a single name like "Plato" or "Madonna".

0
0

Have you tried specifying the author inside a \bibcorporate{}?

From apacite manual:

author

The author(s) of the work. This may also be a corporate author when applicable, but some specific measures must then be taken to prevent the corporate name from being interpreted as a first name and last name (such as “Association, A. P.”):

author = {{\bibcorporate{American Psychological Association}}},

It is important to surround the \bibcorporate{Author} by an additional pair of braces.

1
  • 2
    Thanks but that seems to be not working with biblatex...
    – holger
    Commented Feb 4, 2019 at 20:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .