9

I am trying to set the following minimal document:

\documentclass[a4paper,11pt]{article}
\usepackage{fontspec}
\setmonofont{Inconsolata}
\begin{document}
\begin{verbatim}
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
<html lang="en">
<head>
    <title>An Example of a Web page</title>
</head>
<body>
    <p>This is an example of a Web page</p>
</body>
</html>
\end{verbatim}
\end{document}

I would like to keep the HTML text as it exists in the file and use the verbatim environment for that.

I want symmetrical typewriter double quotes rather than the typographic right/left paired double quotes.

I get the latter rather than the former when I compile the above file with lualatex.

How might I get what I want?

=== Addendum 1 ===

I downloaded the font from the blog post link suggested by Khaled Hosny below, unzipped it, and installed it on my Linux system as a system font.

fc-list | grep Inconsolata shows the font as 'Inconsolata-dz:style=dz'.

I then changed the single line with Inconsolata to Inconsolata-dz in the file above.

When I tried compiling with lualatex, it terminates prematurely with these lines:

luaotfload | Updating the font names database:
luaotfload | Scanning TEXMF fonts...
luaotfload | Scanning OS fonts...
! Font \zf@basefont=name:Inconsolata-dz at 10pt not loadable: metric data not found or bad.
<to be read again> 
                   \scan_stop: 
l.3 \setmonofont{Inconsolata-dz}
2

1 Answer 1

5

What I'm getting here is the ASCII double quote, but it is drawn curly not straight in the font, and that is a known (mis)feature of Inconsolata, check this blog post for a modified version with straight quotes.

5
  • Thank you both for your replies. I was not aware of the (mis)feature of this font and even less aware of the workaround. My problem has been solved now.
    – chandra
    Commented Oct 31, 2010 at 17:32
  • I would appreciate an explanation of how to use your fix to use your modified version of inconsolata in a document. Thanks!
    – Seamus
    Commented Oct 31, 2010 at 21:34
  • I downloaded the font from the blog post link, unzipped it, and installed it on my Linux system as a system font.
    – chandra
    Commented Nov 1, 2010 at 7:34
  • Please see addendum in my Original post on problems encountered with using Inconsolata-dz. Grateful for pointers.
    – chandra
    Commented Nov 2, 2010 at 4:50
  • @chandra: I already replied above; this usually means the font is not seen by luaotfload, but the installation went fine on my side. Commented Nov 3, 2010 at 15:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .