7

I'm preparing a manuscript for a journal that demands a style file (copernicus2.cls) that's not compatible with amsmath. I want to display some aligned equations, but the lack of amsmath means I can't use the align environment. eqnarray's inconsistent spacing offends me, so I'm wondering if there's some kind of workaround that will let me achieve the effect of align without including the amsmath package?

3
  • 1
    @Dilaton I'd like to continue this in chat but I don't know how. Can you create a room?
    – N. Virgo
    Commented Nov 15, 2013 at 10:58
  • 2
    @dilaton I agree with you, I think. I'm on a mobile device so can't easily check all the questions you posted, but generally I think those kinds of high level questions can be detagged, perhaps with some modification in some cases.
    – N. Virgo
    Commented Nov 15, 2013 at 13:32
  • 2
    @dilaton I think the definition in emilio pisanty's proposal is going in the direction you suggest. I'll do what I can to make sure it gets there. I'll be busy this weekend too though unfortunately. (Many apologies to the mods here for the irrelevant thread, I just don't want to try and figure chat out while I'm browsing on a phone)
    – N. Virgo
    Commented Nov 15, 2013 at 13:42

2 Answers 2

11

I guess you mean the copernicus2.cls provided by the Biogeosciences. The files can be found on there website.

The class file loads the package txfonts which must be loaded after amsmath. The package txfonts has a mechanism to redefine some internal commands of amsmath which amsmath doesn't have.

You can load the package amsmath as follows to use align:

\RequirePackage[fleqn]{amsmath}
\mathindent0pt
\documentclass[journal abbreviation]{copernicus2}
\begin{document}
\begin{align}
1+1&=2 \\
    2&=2
\end{align}
Test
\[1+1=2\]
\end{document}

EDIT: Set option fleqn and mathindent=0pt

enter image description here

7
  • Hm, actually there's still one issue, which is that the copernicus2.cls file aligns equations to the left instead of centering them, but the ones I enter with align are still centered. What's the best way to make the align ones match the others?
    – N. Virgo
    Commented Mar 9, 2012 at 12:29
  • @Nathaniel: Please see my edit Commented Mar 9, 2012 at 12:38
  • sorry for being dense - fleqn still indents the align equation a bit, and putting \setlength{\mathindent}{0mm} (or any other value) in my header doesn't seem to affect it.
    – N. Virgo
    Commented Mar 9, 2012 at 14:49
  • Also, mathindent=0pt as an option for amsmath doesn't work either, it just says it's an unknown option.
    – N. Virgo
    Commented Mar 9, 2012 at 14:50
  • @Nathaniel: I can't understand your problem. I will add an image of my output. Commented Mar 9, 2012 at 15:17
3

@Marco, amsmath does not load amssymb. The problem is two fold.

copernicus2.cls load txfonts.sty which define various \XintY macros which amsmath also define. Since amsmath define these using \newcommand the OP get an error because they are already defined.

This works

\documentclass[journal abbreviation]{copernicus2}
\let\iint\relax
\let\iiint\relax
\let\iiiint\relax
\let\idotsint\relax
\usepackage{amssymb,amsmath}
\begin{document}
\begin{align}
1+1&=2 \\
    2&=2
\end{align}
\end{document}

Though Marcos solution may be better, because the solution above may use a different font for those integral symbols than the Journal intended.

3
  • Please see my edit (17min ago) ;-) Commented Mar 9, 2012 at 10:10
  • better, but the journal should provide a better style (is there still kerning issues with txfonts?)
    – daleif
    Commented Mar 9, 2012 at 12:06
  • @Deleif: A user of copernicus should send a request to Biogeosciences. The kerning issue is the same as usual ;-) Commented Mar 9, 2012 at 12:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .