I have been using TeX Live 2010 on my Windows 7 computer for some time now, without problems. Recently I decided to use the TeX Live Manager to check for updates, which were successfully installed. The next time I tried to start the Manager, I started getting the perl.exe has stopped working error. The TeX Live Installation itself is working just fine, the only problem is the TeX Live Manager. I have tried restarting the computer but it didn't help. What should I do to get it to work?

  • 3
    We see these from time to time (no idea why). Though, wouldn't have helped you anything as you can no longer update a TL'10
    – daleif
    Commented Mar 9, 2012 at 9:51
  • 1
    It seems the Problem was caused by updating the internal Perl installation for TeX Live - I guess it was not properly installed or something. I'll just download the texlive2011.iso image and do a fresh install of TeX Live 2011. Commented Mar 9, 2012 at 10:07
  • Why iso? I've never had problems with doing a net install. You are going to download almost as much updating the TL11.
    – daleif
    Commented Mar 10, 2012 at 15:39
  • 1
    Several months ago I had the same issue. I double clicked install-tl, installation began but stopped at the middle with that error. I closed the installation and reinstalled from the command prompt and succeeded. Commented Apr 27, 2012 at 16:20
  • 1
    @SeanAllred: I am a batwoman. :-) Commented Apr 13, 2013 at 13:09

8 Answers 8


When I tried installing TeX Live 2011 over the Internet in Windows 7 64-bit (running install-tl batch file), I got the same perl.exe has stopped working error. I was thinking to install a TeX using ISO image but finally decided to try again the first method however this time before running the install-tl I installed Perl for Windows (Strawberry Perl version from http://strawberryperl.com/ and then I run the install-tl again. And now everything was fine and I successfully installed the Tex Live 2011!


run install-tl-advanced.bat as administrator.

I've had the problem on my two laptops: one had ActivePerl installed, the other one didn't have any Perl installed so I installed Strawberry Perl on it, following Vladimir's suggestion. The error message appeared on both systems with/without Perl. Running the advanced bat file as administrator worked. I cannot say if Perl was or wasn't needed after all. But I can confirm that running as admin was necessary in my case (others report no such need).

  • I don't think it is necessary to run it as admin, at least not unless it is a multi user system. I'm going to investigate the problem, when it get a new computer (it has been delayed)
    – daleif
    Commented Sep 25, 2012 at 15:12
  • I recently encountered a similar problem with TeXLive 2012, but by running the advanced install things appeared to work. Commented Sep 30, 2012 at 4:55
  • I had the same issue with TeXLive 2013. After installing Strawberry Perl and restarting my computer, I had to run the admin setup in order for it to work. Hope this helps others...
    – GregH
    Commented Aug 26, 2013 at 12:17

I decided to mount my texlive2010.iso DVD image in an attempt to see if I could do a repair or something like that. Here's what I did:

  1. I browsed the files on the DVD and went to 'DVD-Drive:'\tlpkg\tlperl,
  2. I copied all the files in the folder,
  3. I then went to C:\texlive\2010\tlpkg\tlperl and deleted all the files there, after which I pasted the files copied from the corresponding directory on the DVD. I then launched TeX Live Manager and there it was - Working Perfectly!

It seems the Problem was caused by updating the internal Perl installation for TeX Live - I guess it was not properly installed or something. I'll just download the texlive2011.iso image and do a fresh install of TeX Live 2011.


The issue is that you don't have perl installed. Following up on @Vladimir, it seems when you just click the install batch, it takes the perl GUI by default. Since you don't have that perl GUI (outdated maybe?), it give that error.

This can be fixed by running a different GUI. I recommend simple text. Go to the directory on the console, and type:

install-tl -gui text

This will use the text GUI instead of the perl one. There is also:

install-tl -gui wizard

I'm assuming it would use the windows wizard, but I never tried it. I like command-line UIs.

EDIT: made it more clear what I meant by "not having perl".

  • I don't think this answer is correct. The installer includes a minimal Perl installation and should work without installing Perl. Anyway, the whole installer is written in Perl, not just the GUI, so -gui text uses Perl too.
    – mpg
    Commented May 2, 2012 at 7:27
  • I meant the GUI. It seems it uses some GUI written in perl, and something is wrong with it (outdated?). So running the text GUI fixed it for me.
    – Nacht
    Commented May 8, 2012 at 17:01

install-tl.bat must be run as Admin on Windows 7. Turning off UAC can work but is not recommended.

MikTeX can suffer even stranger problems under Windows 7. Use the portable version, but avoid USB sticks, as it tries to install thousands of tiny files.

  • Or do an installation outside of %ProgramFiles% (usually C:\Program Files) / %ProgramFiles(x86)% (usually C:\Program Files (x86)).
    – Speravir
    Commented Sep 30, 2012 at 3:52

Today I get the same error and I used the command:

install-tl -gui=text

and it works.


I tried both web installers as well as .iso file. perl crashed on both of them. Mine is Windows 7 Professional (legal copy updated till date). I had an old .iso of TeX Live 2012. The installation work smoothly.

It seems that there is some compatibility issues in TeX Live 2013 with Windows 7 Pro. Hope someone notices it and fixes it in the next version.


This may occur when TL manager itself needs to be updated. You can run tlmgr update --self as an administrator to do so.

P.S. Under Windows, tlmgr is found in C:\texlive\2018\bin\win32\

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .