I have the same problem as described by adam.baker in this post:

\includepdf only shows first page, despite having multiple pages.

(This seems to be not limited to pdfpages, because graphicx with

\includegraphics[page=2]{external} also shows ONLY page 1.)

I have inserted my log file as answer in the original post.

Any help would be greatly appreciated.


enter image description here enter image description here

closed as off-topic by egreg, Phelype Oleinik, Mensch, Raaja, Stefan Pinnow Feb 7 at 18:09

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • You are using which LaTeX compiler: pdflatex, lualatex, xelatex? Try \usepackage{mwe} ... \includegraphics[page=2]{example-image-a4-numbered} and check if it works with that to make sure it is not your external file which is the problem. – Martin Scharrer Feb 7 at 13:42
  • Your system is not up-to-date. Run the miktex console update as user to update the packages in your user tree. – Ulrike Fischer Feb 7 at 13:52
  • @MartinScharrer: please refer to original post - the "external file" has been compiled as described there. Log shows compiler used (pdflatex). I tried your hints as well; shows only page one (black "1" on red ground). Both for \includepdf and \includegraphics. – Martin Brennecke Feb 7 at 15:50
  • @UlrikeFischer: thought so too - but MikTeX Console shows no updates available (both for user and admin). This is exactly as described in original post. – Martin Brennecke Feb 7 at 16:01
  • 4
    I'm voting to close this question as off-topic because the issue was due to a malfunctioning TeX distribution, solved by doing appropriate maintenance. – egreg Feb 7 at 16:51

@UlrikeFischer: thank you very much indeed for pointing out the incorrect paths! I was able to resolve the problem with the "cleanup" entry of MikTeX Console. Just clicked "Reset personal MikTeX configuration" (it took a while for the operation to complete). After that it worked like a charm.

enter image description here

Thanks again a lot!

Not the answer you're looking for? Browse other questions tagged or ask your own question.