1

I have TL2018 on windows 10. When trying to update packages with tlmgr, it said that tlmgr itself needs to be updated.

However, the command tlmgr update --self failed for me with the following error message

λ tlmgr update --all --self
tlmgr.pl: package repository http://anorien.csc.warwick.ac.uk/mirrors/CTAN/systems/texlive/tlnet (not verified: gpg unavailable)
tlmgr.pl: Preparing TeX Live infrastructure update...
DO NOT CLOSE THIS WINDOW!
TeX Live infrastructure update in progress ...
Detailed command logging to "\\icnas1.cc.ic.ac.uk\kg314\texlive\2018\temp\update-self.log"
Could not change working directory to "\\icnas1.cc.ic.ac.uk\kg314\texlive\2018\temp\.."
Aborting infrastructure update, no changes have been made.

How to fix this issue? I am unable to install any packages too in this current state.

Update

I tried to do a fresh installation of texlive on the machine. However, after reaching the tar package, the installation crashes abruptly with the following entry appearing last in the log.

TLUtils::untar: H:\install-tl-20190207\tlpkg\installer\tar.exe xmf C:\Users\kg314\AppData\Local\Temp\goATAeqfOX\xskZVdlZXH/kpathsea.win32.tar failed (in H:/texlive/2018)
TLPDB::_install_package: untar failed
Installation failed.
Rerunning the installer will try to restart the installation.
Or you can restart by running the installer with:
  install-tl-windows.bat --profile installation.profile [EXTRA-ARGS]
or
  install-tl-advanced.bat --profile installation.profile [EXTRA-ARGS]

Now, I am in an inconsistent state. Any further tlmgr update --all simply results in an error

tlmgr.pl: Fundamental package texlive.infra not present, uh oh, goodbyeShould not happen, texlive.infra not found at \\icnas1.cc.ic.ac.uk\kg314\texlive\2018\texmf-dist\scripts\texlive\tlmgr.pl line 7344

11
  • Have you been able to update before? I'm a little weary about your use of unc paths (\\....), they might not work. But if you have been able to update before...
    – daleif
    Feb 7, 2019 at 21:06
  • @daleif yes, totally was able to update before ever since TL2018 was released. Something bad happened just today (07/Feb/2019). Even a fresh install fails complaining that untar failed, and that too just for a minimal install Feb 7, 2019 at 21:10
  • Hmm, no clue then (I don't use Windows). Just for the heck of it: have you tried a different mirror? You mention untar errors, could you cite those?
    – daleif
    Feb 7, 2019 at 21:16
  • @daleif Yes. Problems with all mirrors. Have updated the question with untar errors. Feb 7, 2019 at 21:20
  • 1
    Well I have no idea in what state your system is after your reinstallation tries. I got an error from tlmgr and followed the disaster recovery instructions tug.org/texlive/tlmgr.html and it worked. But you should better ask on the texlive list. There are the people who know the system. Feb 7, 2019 at 21:36

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.