1

I am using TeXmaker because it has the preview to the right.

However, upon installing into my new laptop, I've noticed that the preview of the internal PDF viewer was quite blurry. I would like to know how to improve the quality of the render. (screenshot below)

The PDF is blurry! Also the icons!

You can also see that the GUI icons are blurry. I am not sure if it is related to that.

I've looked at the following existing questions and I would reason out why they didn't help:

I would prefer a solution that actually fixes the TexMaker issue. I'm guessing here, but maybe there's a way to give a custom command to the Built-In PDF Viewer which tells it to render itself in a higher quality.

However, if no fix can be found, I would be open to suggestions on which other TeX editor would have a built-in viewer as well. I installed TeXstudio and I run into the same problem of blurry PDFs.

Any help would be much appreciated. Thanks in advance.

1

Ok. So I solved it. Sort of.

I was using KDE and it has this "Scale Display" option. I had it at 1.3 and I guess this feature wasn't so compatible with TexMaker. I set it to 1 and things got fixed.

  • I would like to know who to report this to. KDE or TexMaker? Or both. And how. – Guissmo Feb 8 at 16:02
  • It not a problem its a feature as per previous answers down to using small pixels on big screens it is controlled by Microsoft true type on windows aggravated by QT scalling on all platforms and the application not adjusting for ever global user combination possible. – user170109 Mar 10 at 22:20
  • 1
    I'm sorry, I don't think I understand what you're saying. First of all, I would like to know how this issue is related with Microsoft True Type fonts as I'm using Linux. Second, I don't understand how this can be a font issue when opening the compiled PDF on another application works fine. Third, I don't understand how this is a feature if it prevents the user from enjoying an intended feature. One could say it doesn't support compatibility with KDE, but I would not go as far to calling it a feature. – Guissmo Mar 11 at 23:52
  • I agree it not a desirable feature , my comment about windows is for other users since Texmaker is cross platform and currently I have it on one windows screen at 100% zoom where its doing my eyes in since it was launched at 1.5 scale so to be running Texmaker in this state is an issue though I personally could change many setting to clear it but then other QT apps would be affected and need resetting – user170109 Mar 12 at 0:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.