2

tex4ht spuriously italicizes footnote hooks (e.g., "1" for the first footnote) at the bottom of the page when the first word of the footnote is italicized.

MWE:

%!TEX TS-program = xelatex
%!TEX encoding = UTF-8 Unicode

\documentclass[12pt]{memoir}
\usepackage{ifmtarg}
\usepackage{calc}

%Greek
\newcommand{\greek}[1]{#1}
\newcommand{\gk}[1]{#1}

%Arabic
\newcommand{\ar}[1]{#1}
\newenvironment{arab}{}{}

% Bibliography etc
\usepackage[notes]{biblatex-chicago}
\addbibresource{biblatex-examples.bib}


\usepackage{textcomp} % For angle brackets `\textlangle` and `\textrangle`

\begin{document}


%%%%%%%%%%%%%%%%%%%%
%%%    My text goes here:    %%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%

Text.\footnote{Ordinary footnote: \cite{knuth:ct}.}

Text.\footnote{\emph{Italicized} first word of footnote.}


%%%%%%%%%%%%%%%%%%%%
%%%    My text ends here:    %%%%%%%%%%%%%%%%%%%%%%
%%%%%%%%%%%%%%%%%%%%

\end{document}

Is there a way to fix this bug?

  • Something similar happens when the first word of a footnote is in boldface: the footnote hook becomes boldface too. – Alex Roberts Feb 10 at 16:31
  • 1
    I cannot reproduce this issue with current version of ooffice configuration, maybe it had been fixed as a consequence of another fix? – michal.h21 Mar 19 at 22:33
  • You're right -- it has been fixed in the new version! Thank you for pointing that out. Perhaps that should become the official answer? – Alex Roberts Mar 23 at 20:57
1

This issue was seemingly fixed by recent tex4ht development, as the current development version produces the following result (the page had been resized to make the screenshot smaller):

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.