2

I try to compile a document as pdf/x and pdf/a with pdfx under LuaLaTeX, and I am already quite successful. One thing still poses problems though: With some fonts I get the following error if I check the resulting pdf/a file with Acrobat: "CIDset in subset font is incomplete (font contains glyphs that are not listed)" (VeraPDF gives the same error, so the issue seems to be real).

Here's a MWE:

\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.xmpdata}
\Title{Test}
      \Author{Simon Spiegel}
      \Language{de-DE}
\end{filecontents*}
\documentclass
{article}
\usepackage{fontspec}
\setmainfont{Palatino Linotype}
[Ligatures={TeX,Common},
Extension = .ttf,
]
\usepackage[a-3b]{pdfx}
\begin{document}
Test
\end{document}

I realise that not everyone will be able to compile this MWE due to the proprietary font, but since the problem only occurs with specific fonts, I had to use this example.

The pdfx manual mentions this error, but only in relation to XeLaTeX. According to the manual, it should not occur with LuaLaTeX.

From what I understand, this seems to be at least to some degree a problem of this specific font, but since I am relying on it, I am looking for a way to fix it.

EDIT

Here's a new MWE with a bunch of fonts which are hopefully more common (the paths have to be adapted of course).

\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.xmpdata}
\Title{Test}
      \Author{Simon Spiegel}
      \Language{de-DE}
\end{filecontents*}
\documentclass
{article}
\usepackage{fontspec}
\setmainfont{Georgia}
[Ligatures={TeX,Common},
Extension = .ttf,
]

\newfontfamily\fontone{Verdana}
[Ligatures={TeX,Common},
Extension = .ttf,
]
\newfontfamily\fonttwo{Cambria}
[Ligatures={TeX,Common},
Extension = .ttf,
Path = {/Users/simi/FontExplorerX/C/Cambria/}
]
\usepackage[a-3b]{pdfx}
\begin{document}
Test

\fontone
Test

\fonttwo
Test
\end{document}

All these fonts give me the same error. I wonder if this only happens with .ttf OpenType fonts.

  • I don't have the font, so I can't test. – Ulrike Fischer Feb 10 at 16:19
  • I added additional fonts. I hope one works for you. – Simifilm Feb 10 at 18:44
6

You need to set the variable omitcidset to 1 (thanks to Hans Hagen ...):

\documentclass{article}
\usepackage{fontspec}
\setmainfont{Georgia}
\usepackage[a-3b]{pdfx}
\pdfvariable omitcidset=1
\begin{document}
Test
\end{document}

(probably pdfx should do it, so better inform the maintainer)

enter image description here

  • Thanks, that did the trick. Strange that this is not automatically set with the pdf/a setting of pdfx. – Simifilm Feb 11 at 13:00
  • Imho the maintainer is mostly working with pdftex - and I had to ask too ;-) (it is documented, but one tends to skim over such stuff). – Ulrike Fischer Feb 11 at 13:03
  • Is it documented in the pdfx manual? I only see this problem mentioned in relation to XeLaTeX and the omitcidset isn't mentioned anywhere. – Simifilm Feb 11 at 13:54
  • It is documented in the luatex manual. – Ulrike Fischer Feb 11 at 13:58
  • Ah, ok. Should probably also be included in pdfx. – Simifilm Feb 11 at 14:08

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.