2

Trying my first steps in the Tex world. I'm trying to achieve the result for : Pandoc Resume, which creates an intermediary tex file before a convertion to pdf using mtxrun.

Unfortunately, I cannot manage to convert the tex file into a pdf file.

mtxrun | unknown script 'context.lua' or 'mtx-context.lua'

It seems to be a fairly old error, dating back to 2011, and the internet resources say to do:

luatools --generate

But despite this operation, I still have the same error.

mtxrun | unknown script 'context.lua' or 'mtx-context.lua'

I cannot see clearly what's going wrong. So it is not easy to find the solution. Any insight?

I am using the linux distribution Nixos v18.03 mtxrun is version 1.32 from package: texlive.combined.scheme-context

  • 5
    Welcome! What operating system are you using, and what TeX distribution (i.e., how did you install TeX and ConTeXt)? The repo you linked to has instructions for Debian / Ubuntu, Fedora, Arch, and OSX; did you use one of these? Also, at the very end, it suggests mtxrun --generate; did you try this? – ShreevatsaR Feb 10 at 22:30
  • I have edited the question: I use Nixos and the texlive.combined.scheme-context ackage. I did not read the very end... And after running this command it solves the problem. – Stephane Rolland Feb 10 at 22:47
  • 5
    That's great! Please post it as an answer (yes it's ok to answer your own question) and mark it as accepted, so that someone else who has the same problem can find the solution here (instead of whatever you found on the internet). – ShreevatsaR Feb 10 at 22:52
  • @ShreevatsaR I'm gonna do this. Just thinking about not paraphrasing too much. Also I want to check how I can modify the nixos derivation/package file so as to complete this operation automatically. – Stephane Rolland Feb 11 at 11:38
  • @ShreevatsaR and StephaneRolland Please write an answer or close this question as off-topic because it was solved in the comments. – Henri Menke Feb 12 at 10:34
3

As suggested at the end of this page, running the command:

mtxrun --generate

solves the problem. Further calls to texlive now execute successfully.

I am searchin for a way to automatically do this in the nixos derivation. I'll edit with the result here when I'm done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.