2

I am making a Technical Manual using the memoir Class, since I heard it is very customizable. Far now I've got this:

\documentclass[8pt,a5paper]{memoir}

\usepackage[utf8]{inputenc}
\usepackage[english]{babel}

\usepackage{graphicx}
\usepackage{float}

\usepackage{microtype}

\hoffset = -20pt
\voffset = -20pt

\usepackage{lipsum}

\begin{document}

\pagenumbering{gobble}% Remove page numbers (and reset to 1)
\clearpage
\thispagestyle{empty}

\begin{huge}
\textbf{Apparatus User's Guide}
\end{huge}

\begin{figure}[H]
  \centering
  \includegraphics[width=0.9\textwidth, height=1\textwidth]{Images/Main/Plasma-Ball.jpg}
\end{figure}

\newpage

\pagenumbering{Roman}

\begin{normalsize}

\tableofcontents

\end{normalsize}

\newpage

\thispagestyle{plain}

\pagenumbering{arabic}

\section{Introduction}

\begin{figure}[H]
  \centering
  \includegraphics[width=0.4\textwidth, height=0.4\textwidth]{Images/Main/Plasma-Globe.jpg}
  \caption{Plasma Globe}
\end{figure}

\lipsum

\newpage

\thispagestyle{plain}

\section{Components}

\textbf{Mechanics}

\lipsum

\textbf{Electronics}

\lipsum

\newpage

\section{Assembling}

\lipsum

\newpage

\section{Turn it on}

\lipsum

\newpage

\section{Calibration}

\lipsum

\newpage

\section{TroubleShooting}

\lipsum

\end{document}

But I am not very sure about how they look certain things and I don't know how to change them. For example the table of contents. All the sections start with 0.X instead of X.

enter image description here

The other pages have in the upper right corner the word Contents. I think it is irrelevant placing that word in that place and I don't know how to remove it.

enter image description here

The Cover Page, I don't know if it is fine to let it the way it looks enter image description here

I would appreciate any other suggestions for an User's Guide either using packages or configuring the memoir class. Thanks


Edition

enter image description here

enter image description here

enter image description here

  • 2
    Use \chapter{} instead \section{}. Then you get correct numbers ... – Kurt Feb 11 at 0:43
  • But if I use chapter, now in the table of contents, the multiple dots don't appear – Delfin Feb 11 at 1:00
  • Yeah, but I don't think a user manual should have chapters. It looks strange for me. I uploaded a new photo of how it looks with Chapters, and it looks like a book, and is not. It is a Technical Manual – Delfin Feb 11 at 3:25
  • What manual? Also the table of contents should list itself as a content? – Delfin Feb 11 at 3:39
2

To get rid of your issues you need to change the code a little bit. Please note, that memoir does not support to change the line for a chapter in TOC (to add dotted line).

The code changings I marked with <====== in the following MWE:

\documentclass[%
  8pt,
  a5paper,
  article % <===========================================================
]{memoir}

\usepackage[utf8]{inputenc}
\usepackage[english]{babel}

\usepackage{graphicx}
\usepackage{float}

\usepackage{microtype}

\hoffset = -20pt
\voffset = -20pt

\usepackage{lipsum}


\begin{document}

\pagenumbering{gobble}% Remove page numbers (and reset to 1)
\clearpage
\thispagestyle{empty}

\begin{huge}
\textbf{Apparatus User's Guide}
\end{huge}

\begin{figure}[H]
  \centering
  \includegraphics[width=0.9\textwidth, height=1\textwidth]{example-image}
\end{figure}

\newpage

\pagenumbering{Roman}

\begin{normalsize}

\tableofcontents* % <===================================================

\end{normalsize}

\newpage

\thispagestyle{plain}

\pagenumbering{arabic}

\chapter{Introduction} % <==============================================

\begin{figure}[H]
  \centering
  \includegraphics[width=0.4\textwidth, height=0.4\textwidth]{example-image-a}
  \caption{Plasma Globe}
\end{figure}

\lipsum

\newpage

\thispagestyle{plain}

\chapter{Components}

\textbf{Mechanics}

\lipsum

\textbf{Electronics}

\lipsum

\newpage

\chapter{Assembling}

\lipsum

\newpage

\chapter{Turn it on}

\lipsum

\newpage

\chapter{Calibration}

\lipsum

\newpage

\chapter{TroubleShooting}

\lipsum

\end{document}

It results then for example in the following TOC:

TOC

You can open the manual of memoir on your computer by typing in your console/terminal: texdoc memoir.

As you can see the pdf file is in A5 format (the german "Seiengröße" means page size in english):

enter image description here

  • How can I make a little bit larger the word Content?. And how can I make the body of the document larger too, because the page numbering appears too high. I uploaded a photo – Delfin Feb 11 at 17:07
  • I think partially solved it by changing \footskip = 50pt and \textheight = 400pt ... But now what got me worry is why a a5 paper appears on an a4 paper. Shouldn't appear in an a5 paper? – Delfin Feb 11 at 17:35
  • I am not sure if it is a5. See the last photo I uploaded – Delfin Feb 11 at 23:27
1

I have some answers for you but you have asked too many questions in your comments. Here is something you may work with:

\documentclass[%
  % 8pt   % no 8pt option try 9pt
  9pt,
  a5paper,
  article, % chapters set as sections and so on
]{memoir}

\usepackage{graphicx}

\setulmarginsandblock{1in}{2in}{*} % change the layout, see the manual
\checkandfixthelayout

\usepackage{lipsum}

\begin{document}

\begin{titlingpage} % the title page

{\huge\bfseries{Apparatus User's Guide}}

\begin{center}
\includegraphics[width=0.9\textwidth, height=1\textwidth]{example-image-b}
\end{center}
\end{titlingpage}

\renewcommand{\cftchapterdotsep}{\cftdotsep} % put dots in chapter ToC entries
\newfixedcaption{\figcaption}{figure} % for a non-float figure caption

\tableofcontents*
\listoffigures

\chapter{First major heading}
\section{A minor heading}

\lipsum[1]

\begin{center}
\includegraphics{example-image-duck}
\figcaption{A duck} % figure caption but not in a float
\end{center}

\lipsum[2]

\chapter{Second major heading}
\section{Minor heading}

(1) \lipsum[1]

\end{document}

Please read the relevant portions of the manual (> texdoc memoir); I know it is large but it covers a lot of ground.

There is no 8pt class option, the nearest is 9pt which I have difficulty in reading.

Use the article class option to get the result looking like an article. The downside is that you have to use \chapter instead of \section for the main divisions. The upside is that if you later think you should have used the report or book class all you have to do is remove the article option.

I suggest you do not use the [H] option for floats, which turns them into fixed items (see HEINEOUS ). memoir has its own way of dealing with this.

If you are changing the layout then memoir provides a comprehensive means of doing this. You should never need to change the values of \hoffset and \voffset which are down in the nitty-gritty of TeX..

  • If there isn't a 8pt class option. What size of the font was I using? – Delfin Feb 14 at 16:09
  • @Delfin The default is 10pt. – Peter Wilson Feb 18 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.