3

I have a little problem with the model5-names bibliography style in the elsarticle document class. Instead of getting

(author, year)

citation call-out I'm having

author (year)

How to get a parenthesis-style citation call-out?

  • 2
    Try using \citet. natbib discourages use of the generic \cite and recommends either \citep or \citet. – moewe Feb 11 '19 at 16:04
  • Oh, sorry, it should have been try \citep with p in my comment above. I think you could also try \cite[]{key}, but really using \citep is the better option. – moewe Feb 11 '19 at 17:00
3

The issue you're experiencing is not related directly to either the elsarticle document class or the model5-names bibliography style. Instead, it is caused by the following twin facts: (a) the elsarticle document class automatically loads the natbib citation management package; (b) if an author-year citation style (as is appropriate for the model5-names bibliography style) is in use, the natbib package treats \cite{...} (though not \cite[]{...}!) as an alias for \citet{...}, or "text-style citation".

What to do if you want to get a "parenthetic-style citation" rather than a "text-style citation"? Just type \citep{...}.

| improve this answer | |
  • Point (b) is not entirely accurate. \cite actually behaves like \citep for numeric styles and its behaviour for author-year styles depends on the presence (or absence) of the optional argument, compare \cite[]{sigfridsson} and \cite{sigfridsson}. – moewe Feb 11 '19 at 17:04
  • @moewe - I've edited the answer to state explicitly that \cite is an alias for \citet if the authoryear option is passed to natbib (as should be done for the model5-names bibliography style). The fact that the outputs of \cite[]{...} and \citep{...} look the same is, in my opinion, more likely to be a fluke than a conscious design choice. At any rate, if the natbib package is in use -- as is the case if the elsarticle document class is employed -- one should be purposeful about the citation call-out forms and therefore not use \cite, but only \citep and \citet. – Mico Feb 11 '19 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.