I couldn't find it anywhere here, but sorry in advance if this is a repeated question.

When using Texshop on my Mac, when I do the following...

  1. Type out f(x) = 2x + 3
  2. highlight f(x) = 2x + 3
  3. type $

It will do a "autofill" and surround my f(x) = 2x + 3 with $'s, resulting in $f(x) = 2x+3$.

This is absolutely driving me mad. It does similarly with quotations, parentheses, and other similar commands. Where can I disable this feature?

  • Welcome to TeX.SE! You need a $ at the beginning and another $ at the end. So why do you want to type $ twice instead of once?
    – user156344
    Feb 13, 2019 at 7:42
  • I realize I need both $'s at either end. I just don't like this feature and would like to disable. For example, if I do the following: 1. Type out $f(x) = 2x + 3$ 2. Realize I don't want this and highlight $f(x) = 2x + 3$ 3. type $ The result is $$f(x) = 2x + 3$$, where all I wanted to do was delete/replace it all with just a single $. Feb 13, 2019 at 7:44
  • 1
    Select the text and hit DELETE before $. It's easier.
    – egreg
    Feb 13, 2019 at 11:19

1 Answer 1


The following approach works with version 4.24 of TeXshop. (It may work with earlier versions as well, but I have no way of testing this conjecture.)

  • Open TeXShop
  • From the top ribbon, select "TeXShop" -> "Preferences..."
  • Select the "Editor" tab. You should be looking at something like this:

enter image description here

  • Unselect the "Editor Can Add Brackets" box in the left-hand column

  • Click on "OK" in the bottom right hand corner

Happy TeXShopping!

Of course, with this approach, if you now highlight f(x) = 2x + 3 and then type $, the highlighted material will be wiped out and replaced with $. Or, if you highlight f(x) = 2x + 3 and type (, the highlighted material will be wiped out and replaced with (. In contrast, if the "Editor Can Add Brackets" box were checked, TeXshop would not wipe out the highlighted material and, instead, surround it with matching $ symbols, matching parentheses, etc.

  • Perfect, thank you. I don't like auto-filling features. Feb 17, 2019 at 5:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.