0

I'm using TexWorks to write a journal paper with citations. I have the .tex and .bib files and some figure files and use XeLaTeX+MakeIndex+BibTeX to produce the .pdf document. Everything works. The references are displayed correctly. But my TexWorks only produces the .pdf and .synctex.gz files. The .bbl file, as required by arXiv, is not generated. My TeXworks version is 0.6.2 (MiKTeX 2.9.6930 64-bit). How do I enable my TeXworks to generate the .bbl file?

An example of my .tex file is given below:

\documentclass[aps, superscriptaddress, showpacs, floatfix, twocolumn]{revtex4-1}

\begin{document}
\title{The title of the paper} 
\author{George}
\affiliation{My affiliation}

\begin{abstract}
The abstract of the paper.
\end{abstract}

\pacs{pacs numbers}
\maketitle

\section{Introduction}
The paper \cite{paper} has done some previous work.

\bibliography{abc_refs}
\end{document}

The .bib file:

@article{paper,
  author = {George},
  journal = {Journal name},
  volume = {12},
  issue = {3},
  pages = {45--67},
  year = {1234},
}

It looks like TexWorks directly generates .pdf without .bbl. Is there an option setting that would tell TexWorks to generate the .bbl file?

  • The extensions are shown. I only have 2 output files with extensions .pdf and .synctex.gz. Not sure how to get other output files generated and I need the .bbl file. – George Feb 15 at 4:04
  • Check if in the settings of the profile in texworks there is the --clean option and remove it. – Ulrike Fischer Feb 15 at 7:42
  • Thanks everybody. I managed to generate the intermediate files by doing the typesetting commands XeLaTeX, MakeIndex, and BibTeX separately. The automated typesetting command XeLaTeX+MakeIndex+BibTeX only produces the .pdf and .synctex.gz files. – George Feb 15 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.