4

My laptop screen is small, So I want to use TexStudio by extending to 2nd screen. There is no problem other software (Matlab, Maple etc.)

But in TexStudio, I think there is a scaling problem, so all writings are nested. It is not readable. Please find the following picture. How can we solve the problem?

enter image description here

3
  • 1
    you could use an external pdf viewer instead. You will save more than 1/3 of the whole space ;) For instance you could look over: tex.stackexchange.com/questions/272151/…. However, IMHO, the answer to this question is primariy opinion-based. – Raaja_is_at_topanswers.xyz Feb 19 '19 at 7:15
  • 1
    Using an external PDF viewer is a good idea, but be aware that some PDF viewers will put a lock on your PDF file. This means you won't be able to produce an updated version of the PDF with TeX as long as it is open in the external viewer. You need to find one that will automatically reload the PDF and show you the updated version when it is produced, instead of blocking it's creation. You could look at SumatraPDF, Okular, or Evince, depending on your OS. – thymaro Feb 19 '19 at 7:27
  • Readers please Note it is the EDITOR NOT VIEWER at fault – user170109 Mar 21 '19 at 13:41
3

Could you unlock the pdf viewer and put it on the second screen ? i work like that every day and never had that scaling issue ...

to unlock the viewer

3

enter image description here
The most common cause for lettering issues in the editor (too small or too large) is due to the user zoom setting if that is combined with other scaling issues it may be producing odd effects.

So the first thing to try is use CTRL and the scroll wheel to adjust your zoom to a reasonable level.

The most likely cause when using dual screens for a mismatch in dpi settings is the system trying to auto match for the differences Preferably both screens should be set to 100%. In this case there are a few advanced editor settings so try this combination.

enter image description here

Finally if you messed about with other font settings you may need to reset so try this first beware it may remove some of your custom settings so it is a good idea to save profile first that is two lines above on the menu (you can then reload if necessary later)

enter image description here

0

Next to your texstudio.exe place a file qt.conf containing

[Platforms]
WindowsArguments = dpiawareness=1

this fixed the problem for me two years ago. Unfortunately, I don't remember where I found the solution. There might however be a different problem that comes from this, described here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.