0

I installed MiKTeX 2.9 and afterwards Texmaker 5.0.3 on Windows 10 and i am trying to "Quick build" a simple file to test it. The file:

\documentclass[11pt]{scrartcl}



\begin{document}
Hello world!
\end{document}

When opening a CMD and typing in pdflatex the ouput is the following This is pdfTeX, Version 3.14159265-2.6-1.40.19 (MiKTeX 2.9.6730 64-bit) and the two commands in the settings are:

LaTeX latex -interaction=nonstopmode %.tex
PdfLaTeX pdflatex -synctex=1 -interaction=nonstopmode %.tex

and that seems correct from what i have read from other posts. When switching from Quick build to PDFLaTeX the error is Logfile not found!

When using pdflatex -synctex=1 -interaction=nonstopmode einsteiger.tex in CMD the error is the following:

This is pdfTeX, Version 3.14159265-2.6-1.40.19 (MiKTeX 2.9.6730 64-bit)
(Fatal format file error; I'm stymied)

I read this one PdfLaTeX in Texmaker doesn’t work: “Could not start the command” but it is not the same, because what was tagged as answer is already in my config. No clue whats wrong here, i can provide screens if something is needed.

  • Well the format file is not there. You need to find out, why miktex couldn't create it (the last time I saw this error, the source of the problem was that the user had two miktex systems, one installed as admin and the other as user, and both were in the path, and so miktex got rather confused ...) – Ulrike Fischer Feb 19 at 14:41
  • in MiKTeX-console ensure TASKS all run to avoid interference as Ulrike has pointed out may be two entries on path so inside console check settings & in terminal type path and check there are not 2 with the word MiKTeX ensure last character of path is not " ideally it should not have a final ; at the very end. Inside Texmaker on commands page ensure the bottom left add to path is clear (save any settings you might want to put back later) top left ensure use a build subdirectory is off (not checked) recheck punctuation in pdfLaTeX command pdflatex -synctex=1 -interaction=nonstopmode %.tex – KJO Feb 20 at 0:47
  • Deleted everything from C:\Users\ski\AppData\Local\Programs\MiKTeX 2.9 and C:\Users\ski\AppData\Roaming\MiKTeX also the PATH: everything miktex related deleted Reinstalled MiKTeX to C:\Users\ski\AppData\Local\Programs\MiKTeX 2.9 and updated everything. pdflatex in CMD now possible from c:\windows\System32\ Creating a pdf with TeXworks is now working, pdf is getting generated. Installing texmaker and getting the same error as above again. Options in a screenshot imgur.com/a/IB2BCQW (bottom left is clear). – Stefan Feb 20 at 14:55
  • btw. i have the same problem on another Windows 10 computer and there was definitely no miktex installed before because its fairly new. – Stefan Feb 20 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.