1

This question already has an answer here:

This is a minimal working example of my code:

\documentclass[12pt]{article}
\usepackage{pstricks-add}
\begin{document}
test
\end{document}

By removing the \usepackage{pstricks-add}, everything works properly. With this line in the code, however, I obtain the error:

! Paragraph ended before \ProvidesPackageRCS@i was complete.<to be read 
again>\par

I have read another thread with the same problem, but there, the answers suggest waiting a few days for the bug to be fixed. The thread, however, was placed a month ago. And I have installed texmaker and MikTex this week.

Also, I can't find older versions of the pstricks-add package to replace the one installed right now.

Has anyone solved this problem yet?

Thank you very much.

marked as duplicate by moewe, Stefan Pinnow, Zarko, user156344, Raaja Feb 21 at 10:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Make sure to run your MikTeX updater in admin and user mode at least twice: See tex.stackexchange.com/q/108447/35864 and tex.stackexchange.com/q/55437/35864. This is very likely caused by a version conflict between packages in your user tree and your global tree. An update in both modes should make sure that the packages in both trees have matching versions again. This 'you have to update in both modes' issue is one of the reason why many people recommend against multi-user MikTeX installations and suggest a single-user setup instead. – moewe Feb 20 at 6:38
  • See also tex.stackexchange.com/q/469005/35864 of which this question is probably a duplicate. – moewe Feb 20 at 6:39
  • BTW: Depending on the way you installed MikTeX you may not have actually gotten the newest updates when you installed it (some packages that came bundled with the installed might have been older). That's why it is usually recommended to run full updates after you installed MikTeX. Just for completeness I should mention that the MWE compiles without errors for me on a MikTeX system updated yesterday morning. – moewe Feb 20 at 6:48
  • Does that mean the issue was solved by updating? – moewe Feb 20 at 7:23
  • 1
    Yes. Updating solved the issue. Since I had downloaded and installed texmaker and Miktex this week I thought it would already be the latest version, but updating was indeed required. Once again, thank you very much. – NeonGabu Feb 21 at 9:14

Browse other questions tagged or ask your own question.