3

I'm trying the change the bibliography style in my document from IEEEtran to apa. I've made a dummy doc with the same preamble as my full doc, and using the same bib file:

\documentclass[a4paper, 12pt]{article}

\usepackage{ifpdf}
\usepackage[latin1]{inputenc}
\usepackage[margin=2cm, left=2cm, top = 2cm, bottom=2cm]{geometry}
\usepackage{amsmath, mathtools}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{graphicx}
\usepackage{epigraph}
\usepackage{wasysym}
\usepackage[none]{hyphenat}
\usepackage[super]{nth}
%\usepackage{subfig}
\usepackage{textcomp}
\usepackage[usenames]{xcolor}
\usepackage{hyperref}
\usepackage{cite}
\usepackage{comment}
\usepackage{setspace}
\usepackage{float}
\usepackage{dcolumn}
\usepackage{caption}
\usepackage{subcaption}
\usepackage{multicol}
%\usepackage[symbol]{footnotemisc}

\usepackage{siunitx}
\usepackage{dcolumn,booktabs}
\newcolumntype{d}[1]{D{.}{.}{#1}}

\let\oldFootnote\footnote
\newcommand\nextToken\relax

\renewcommand{\thefootnote}{\fnsymbol{footnote}} 
\renewcommand\footnote[1]{%
    \oldFootnote{#1}\futurelet\nextToken\isFootnote}

\newcommand\isFootnote{%
    \ifx\footnote\nextToken\textsuperscript{,}\fi}

\captionsetup{font={normalfont},labelfont=footnotesize, width=.6\textwidth}
\newcommand\mc[1]{\multicolumn{1}{c}{#1}} % handy shortcut macro
\newcommand\cjaa{Chinese Journal of Astronomy \& Astrophysics}
\newcommand\pasp{Astronomical Society of the Pacific, Publications}
\newcommand\apj{The Astrophysical Journal}
\usepackage{setspace}
%\singlespacing
%\onehalfspacing
\doublespacing
%\setstretch{1.1}

\begin{document}
Hello world \cite{chj+17}

\bibliography{QSO_bibliography3}
%\bibliographystyle{IEEEtran}
\bibliographystyle{apa}
\end{document}

The commented-out \bibliographystyle works fine to produce the following output:

enter image description here

but when I run the apa command below it, the style doesn't change. I need the citations to look like the ones in this document. I compile the doc 4 times like it says in Step 5 here but it still doesn't change. The contents of my bib file look like

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
@preamble{"
   \providecommand{\pasp}{Publications of the Astronomical Society of the Pacific}
   \providecommand{\cjaa}{Chinese Journal of Astronomy~\& Astrophysics}
   \providecommand{\mnras}{Monthly Notices of the Royal Astronomical Society}
   \providecommand{\apjl}{Astrophysical Journal Letters}
   \providecommand{\ssr}{Space Science Reviews}
   \providecommand{\aap}{Astronomy and Astrophysics}
   \providecommand{\apjs}{Astrophysical Journal Supplement}
   \providecommand{\rmxaa}{Revista Mexicana de Astronom\'{i}a y Astrof\'{i}sica}
   \providecommand{\aj}{Astrophysical Journal}
"}

@ARTICLE{chj+17,
   author = {Curran, S. J. and Hunstead, R. W. and Johnston, H. M. and 
             Whiting, M. T. and Sadler, E.~M. and Allison, J.~R. and 
             Bignell, C.},
    title = "Further Observational Evidence for a Critical Ionising 
             Luminosity in Active Galaxies",
  journal = {ArXiv e-prints},
archivePrefix = "arXiv",
   eprint = {1706.06508},
 keywords = {Astrophysics - Astrophysics of Galaxies},
     year = 2017,
    month = jun,
      url = {http://adsabs.harvard.edu/abs/2017arXiv170606508C},
  adsnote = {Provided by the SAO/NASA Astrophysics Data System}
}
%plus others

I've tried downloading and extracting bst files from here but to no avail. I'm not sure what I'm doing wrong.

EDIT: loading \usepackage[authoryear]{natbib} rather than \usepackage{cite} and calling as \citet{chj+17} results in:

enter image description here

Do I need to change the contents of the bib file too?

  • The screenshot that accompanies your follow-up query would appear to indicate that you didn't perform a full recompile cycle (latex-bibtex-latex-latex) after changing the argument of \bibliographystyle from IEEEtran to apa. What makes me thinks this, you may ask? For one, the apa bibliography style is ancient and doesn't know what to with (and hence simply ignores) the url field. However, the formatted bibliography still shows the contents of the entry's url field. – Mico Feb 21 at 7:06
3

You are currently loading the cite citation management package. It can produce only numeric-style citation call-outs, i.e., [1], [2], etc.

Employing the cite citation management package is fine for the IEEEtran bibliography style, which is designed to create numeric-style citation call-outs. Using cite is not ok along with the apa bibliography style, though, as that style is meant to create authoryear-style, not numeric-stye, citation call-outs.

What to do? Answer: Don't load the cite package. Instead, I recommend you load the natbib citation management package, preferably with the option authoryear:

\usepackage[authoryear]{natbib}
\bibliographystyle{apa}

Happy BibTeXing!

  • Your comment was a step in the right direction, but not quite there; see the edit in the question. – Jim421616 Feb 21 at 2:53
  • @Jim421616 - Did you remember (or know) that it’s necessary to re-run LaTeX twice after running BibTeX? The first LaTeX run updates the items in the formatted bibliography, and the second updates the citation call-outs. So, if you haven’t already done so, please rerun LaTeX on your document one more time. – Mico Feb 21 at 4:05
  • By “re-run LaTeX”, do you mean just compile the document? I compiled it a number of times (>2). Or do I need to change some setting between compiles? Sorry for the noob questions. – Jim421616 Feb 21 at 4:35
  • @Jim421616 - Did you also rerun BibTeX after changing the argument of \bibliographystyle — to apa, right? Assuming the arguments of \bibliography (one or more bib files) and of \bibliography are correct and free of syntactic errors, running LaTeX, BibTeX, and LaTeX twice more should resolve all citation call-outs. – Mico Feb 21 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.