0

In twoside book/memoir documents, using the geometry package and LUALaTeX - and to set up offset printing, (four + pages per sheet):

What should be the expected behavior of bindingoffset?


1. Issue

I have been having some weird inconsistent behavior using the memoir and book classes to create twoside books. And, I am having trouble understanding the behavior of the bindingoffset / gutter is explained in the documentation.

Although there are many questions related to this topic - THIS question pertains to understanding the actual documentation of the geometry documentation.

In one place, the documentations seems to state that the bindingoffset is actually removing space from the inner margin for twoside documents, (which is what is happening in my experience), but in another place it says its supposed to be adding that space to the inner margin.


From the Geometry package documentation:

pg.2 - margins : left (inner), right (outer), top and bottom

pg.9 - bindingoffset removes a specified space from the lefthand-side of the page for oneside or the inner-side for twoside. bindingoffset=hlengthi. This is useful if pages are bound by a press binding (glued, stitched, stapled . . . ). See Figure 6.

pg.10 - Figure 6: The option bindingoffset adds the specified length to the inner margin. Note that twoside option swaps the horizontal margins and the marginal notes together with bindingoffset on even pages (see b)), but asymmetric option suppresses the swap of the margins and marginal notes (but bindingoffset is still swapped).

pg. 29 - ‘bindingoffset’ The macro adds the specified space to the inner margin. 523 \define@key{Gm}{bindingoffset}{\Gm@setlength\Gm@bindingoffset{#1}}%


2. Minimal Working Example:

\documentclass[12pt, twoside, final]{book}
\usepackage{layouts}
\usepackage[                    %
        portrait,
        twoside,                %
        truedimen,
        paperwidth=5.5in,       %
        paperheight=8.5in,      %
        layoutoffset=0in,       % The H/W offset of the page from the stock paper's top left corner.
        hdivide={0.5in,*,0.5in},% {left margin, body text, right margin}
        vdivide={0.5in,*,0.5in},% {top margin, body text, body margin}
%       includehead,            % Includes header in total height.
%       includefoot,            %Includes footer in total height.
%       includemp,
%       vmarginratio=2:3,       % Vertical ratio of top to bottom. Default ratio is 2:3.
%       top=0.5in,              % Height of Top Margin
%       topmargin=0in,          % Vertical space between top margin and header.
        headsep=0.0in,          % Vertical space between header and body text.
        headheight=0.5in,       % Vertical height of header.        
%       bottom=0.5in,           % Bottom Margin
        footskip=0in,           % Vertical space between Footer and Body Text.
        bindingoffset=0.5in,    % Removes/add space from the Left Recto Margin, or Inner
%       hmarginratio=2:3,       % Ratio of left to right, (inner to outer), margin.  Default is 2:3 for twoside
%       inner=0.5in,            % Left Margin on Recto
%       outer=0.5in,            % Righ Margin on Recto
        marginparwidth=0in,     % Width of the Margin Notes Area
        marginparsep=0in,       % Space between margin notes and body text.
        %marginparpush=0in,     % Vertical space between margin notes.
        %oddsidemargin=0in,     % Horizontal space between left margin and body text.
        % ***** Debug Options
        showframe               %
%       showcrop                %
    ]{geometry}


\begin{document}
    Hello World
    \clearpage
    Goodbye Irony
    \clearpage
    \printparameterstrue 
    \setlayoutscale{0.25}\pagediagram   
    \clearpage
    \printinunitsof{in}{\setlayoutscale{0.25}\pagevalues}
\end{document}
  • Pg 9... Removes space from the type area on the inner side – Johannes_B Feb 26 at 6:59
  • @Johannes_B - I am not sure how to reconcile that with the other two explanations in the document. I am pretty sure I am getting unexpected results because I am completely misunderstanding what the documentation is saying. I wouldn't expect any space to be removed, (perhaps shifted?). – elika kohen Feb 26 at 7:12
  • 1
    Use extrem values like 8cm for the offset. And the option showframe – Johannes_B Feb 26 at 7:42
3

You can simply try it:

\documentclass{book}
\usepackage{geometry,lipsum}
\geometry{showframe,margin=2cm,bindingoffset=2cm}
\begin{document}
\lipsum \lipsum \lipsum
\end{document}

enter image description here

It is obvious that the white space in the inner margins looks larger. So from one point of view bindingoffset is adding space to the margin. But on the other side the bindingoffset is not really part of the page layout -- it will disappear in the binding, and by using the option you are making the page and the textwidth smaller so the bindingoffset is removing something from the page.

(That is the simple case, if you use both papersize and layoutsize (or stockwidth/papersize in memoir) then it can get more complicated and carefull tests to check if you get what you want are needed).

  • Thank you for the helpful comment. I have certainly been experimenting with the API. But, as I said - the results are very confusing to me. I included the layouts package diagram in an MWE to try to illustrate that despite the semi-correct margins it is setting, (they are off a bit), I am still getting really weird result values, (which makes it difficult to position marginal thingies). Also, I have no idea why geometry isn't setting exact page values. Could this be the source of my issue? MikTex / LuaLaTeX, TeXMaker, TeXStudio. – elika kohen Feb 26 at 8:24
  • geometry is setting exact values, but the layouts package has rounding errors when converting the sp values to inches. If you calculate e.g. with expl3 paperwidth is exactly 5.5 inches. – Ulrike Fischer Feb 26 at 8:29
  • But why negative margin widths? – elika kohen Feb 26 at 8:32
  • The real evensidemargin (=left margin on even pages) is the value plus 1 inch, (and with oddsidemargin you must add an inch too). For historical reasons TeX has an offset of 1inx1in. – Ulrike Fischer Feb 26 at 8:38
  • Thank you. I am probably reading too much in between the lines to try and figure this out, but: I just tested keeping the offset set to 0, (as in my MWE), and then just commenting out the line altogether. But, I kept getting the same results. Am I misunderstanding the +1 offset, (I did omit the crop marks). I did neglect to say that I am trying to set this up for offset printing, so this is why I am trying to understand this completely. – elika kohen Feb 26 at 8:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.