0

i cant get texliveonfly running, i followed this guide here

How to setup texliveonfly, on any LaTeX editor?

but i get an error message

C:\texlive\2018\bin\win32\runscript.tlu:922: C:\texlive\2018\bin\win32\runscript.tlu:889: program not found (not part of TeX Live): python.exe

i also installed latest python already, still does not work

0

I have solved it, it was a setting while the python installation, which is called "Add Python to environment variables", so i went to windows settings -> apps, found python and clicked on modify, then checked the corresponding box and accepted, now it works.

  • Generally sound like the common solution that the \bin folder containing python.exe needs to be included in the system path beware there may be several environment variable depending on the variant of python in addition to adding the bin to path such as PATH = , PYTHONPATH = and also PYTHONSTARTUP = , It is important to read the section for setting "environment" for the version you are using as each can be noticeably different (however adding the bin to system path is the most common minimal setting) – KJO Feb 26 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.