2

In APA6 style, commas after the journal name and after the volume number (if there is no issue number) should be italicized in reference list. However, the basic apacite package do not take care of it... How can I change this?

My text file looks as follow:

\documentclass[a4paper,man,apacite]{apa6}
\input{preamble}
\input{firstpage}
\begin{document}
\maketitle
\bibliography{references}
\end{document}

My bib file looks as follow:

@article{homan1987cerebral,
  title={Cerebral location of international 10--20 system electrode placement},
  author={Homan, Richard W and Herman, John and Purdy, Phillip},
  doi={10.1016/0013-4694(87)90206-9},
  journal={Electroencephalography and Clinical Neurophysiology},
  volume={66},
  number={4},
  pages={376--382},
  year={1987},
  publisher={Elsevier}
}

@article{tak2013statistical,
  title={Statistical analysis of fNIRS data: a comprehensive review},
  author={Tak, Sungho and Ye, Jong Chul},
  doi={10.1016/j.neuroimage.2013.06.016},
  journal={Neuroimage},
  volume={85},
  pages={72--91},
  year={2013},
  publisher={Elsevier}
}

If anyone could help me, it would be great, because this is driving me crazy!

  • 1
    Welcome to TeX.SE! – Mico Feb 26 at 18:35
  • For future questions you may want to try and make your (already very good) MWE even better: Keep in mind that we don't have access to your files preamble.tex and firstpage.tex, so the lines \input{preamble}\input{firstpage} produce an error when we run the MWE. In this case it would have been enough to replace them with \shorttitle{Foo} to avoid any errors. To catch things like this I always recommend to test-run MWEs in an empty folder before submission. – moewe Feb 26 at 18:47
  • Thank you for your suggestion! I did not specify those files because I thought they were not useful for this kind of issue. But now, I see that it is actually helpful to run the MWE! – Ségolène Guérin Feb 26 at 20:08
1

apacite uses the macro \APACjournalVolNumPages to style journal, volume, number and pages.

The following redefinition should work

\documentclass[a4paper,man,apacite]{apa6}

\makeatletter
\renewcommand{\APACjournalVolNumPages}[4]{%
  \Bem{#1%
    \ifx\@empty#2#3#4\@empty
    \else
    ,
    \fi
  }%             journal
  \ifx\@empty#2\@empty
  \else
    \Bem{#2%
      \ifx\@empty#3\@empty
      ,
      \else
      \fi
    }%  volume
  \fi
  \ifx\@empty#3\@empty
  \else
    \unskip({#3}), %      issue number
  \fi
  \ifx\@empty#4\@empty
  \else
    {#4}%      pages
  \fi
}
\makeatother

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@article{homan1987cerebral,
  title   = {Cerebral Location of International 10--20 System Electrode Placement},
  author  = {Homan, Richard W. and Herman, John and Purdy, Phillip},
  doi     = {10.1016/0013-4694(87)90206-9},
  journal = {Electroencephalography and Clinical Neurophysiology},
  volume  = {66},
  number  = {4},
  pages   = {376--382},
  year    = {1987},
}
@article{tak2013statistical,
  title   = {Statistical Analysis of {fNIRS} Data: A Comprehensive Review},
  author  = {Tak, Sungho and Ye, Jong Chul},
  doi     = {10.1016/j.neuroimage.2013.06.016},
  journal = {Neuroimage},
  volume  = {85},
  pages   = {72--91},
  year    = {2013},
}
\end{filecontents}
\shorttitle{Lorem}
\begin{document}
\nocite{*}
\bibliography{\jobname}
\end{document}

The commas directly after the italic journal and the italic volume number are also in italics.

In case you are using biblatex (biblatex-apa) you want to set the punctfont option.

\documentclass[a4paper,man,biblatex]{apa6}
\ExecuteBibliographyOptions{punctfont}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@article{homan1987cerebral,
  title   = {Cerebral Location of International 10--20 System Electrode Placement},
  author  = {Homan, Richard W. and Herman, John and Purdy, Phillip},
  doi     = {10.1016/0013-4694(87)90206-9},
  journal = {Electroencephalography and Clinical Neurophysiology},
  volume  = {66},
  number  = {4},
  pages   = {376--382},
  year    = {1987},
}
@article{tak2013statistical,
  title   = {Statistical Analysis of {fNIRS} Data: A Comprehensive Review},
  author  = {Tak, Sungho and Ye, Jong Chul},
  doi     = {10.1016/j.neuroimage.2013.06.016},
  journal = {Neuroimage},
  volume  = {85},
  pages   = {72--91},
  year    = {2013},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\shorttitle{Lorem}
\begin{document}
\nocite{*}
\printbibliography
\end{document}

The commas directly after the italic journal and the italic volume number are also in italics.

Or, more explicitly, if biblatex is not loaded via the document class

\usepackage[backend=biber, style=apa, punctfont]{biblatex}
  • +1. Nice touch to encase fNIRS in curly braces! :-) – Mico Feb 26 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.