0

My equation is too big, does not enter the sheet, how do I solve it?

\begin{equation}
    \label{ecuacionTrOpti}
    [(lr: 0{.}1, error: 0{.}1),(lr: 0{.}1, error: 0{.}5),(lr: 0{.}1, error: 0{.}9),
     (lr: 0{.}5, error: 0{.}1),(lr: 0{.}5, error: 0{.}5),(lr: 0{.}5, error: 0{.}9),
     (lr: 0{.}9, error: 0{.}1),(lr: 0{.}9, error: 0{.}5),(lr: 0{.}9, error: 0{.}9)]
    \end{equation}
  • 2
    As usual, a code snippet is not enough, you should provide an MWE! – user156344 Feb 27 '19 at 15:46
  • 3
    Why is it even an equation? Would it not be better as monospaced text? – Steven B. Segletes Feb 27 '19 at 15:47
1

Even if you still need an equation label, would it not be better as mono-spaced text?

\documentclass{article}
\usepackage[usestackEOL]{stackengine}
\begin{document}
This
\begin{equation}
    \label{ecuacionTrOptiA}
  \textrm{\ttfamily\Longstack[r]{%
    [(lr: 0{.}1, error: 0{.}1),(lr: 0{.}1, error: 0{.}5),\\
     (lr: 0{.}1, error: 0{.}9),(lr: 0{.}5, error: 0{.}1),\\
     (lr: 0{.}5, error: 0{.}5),(lr: 0{.}5, error: 0{.}9),\\
     (lr: 0{.}9, error: 0{.}1),(lr: 0{.}9, error: 0{.}5),\\
     (lr: 0{.}9, error: 0{.}9)]
  }}
    \end{equation}
or this:
\begin{equation}
    \label{ecuacionTrOptiB}
  \textrm{\Longstack[r]{%
    [(lr: 0{.}1, error: 0{.}1),(lr: 0{.}1, error: 0{.}5),(lr: 0{.}1, error: 0{.}9),\\
     (lr: 0{.}5, error: 0{.}1),(lr: 0{.}5, error: 0{.}5),(lr: 0{.}5, error: 0{.}9),\\
     (lr: 0{.}9, error: 0{.}1),(lr: 0{.}9, error: 0{.}5),(lr: 0{.}9, error: 0{.}9)]
  }}
    \end{equation}
\end{document}

enter image description here

  • I must use the library usestackEOL? – x-rw Feb 27 '19 at 15:52
  • i have this error: ! Dimension too large. \height ->\ht \@tempboxa – x-rw Feb 27 '19 at 15:59
  • 1
    @x-rw The [usestackEOL] is not a library, but a package option. You can omit the option and instead, in the preamble, type \setstackEOL{\\} – Steven B. Segletes Feb 27 '19 at 16:11
  • 1
    @x-rw That error you cite does not sound like anything from stackengine. – Steven B. Segletes Feb 27 '19 at 16:12
0

Another solution could be to use align and \notag \\ to enter the page.

\begin{align}
    \label{ecuacionTrOptiB} 
    [(lr: 0{.}1, error: 0{.}1),(lr: 0{.}1, error: 0{.}5),(lr: 0{.}1, error: 0{.}9),\notag\\ 
     (lr: 0{.}5, error: 0{.}1),(lr: 0{.}5, error: 0{.}5),(lr: 0{.}5, error: 0{.}9),\notag\\ 
     (lr: 0{.}9, error: 0{.}1),(lr: 0{.}9, error: 0{.}5),(lr: 0{.}9, error: 0{.}9)]
\end{align}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.