0

I have downloaded the portable miktex and I have installed texmaker on my computer. The following screenshot presents by configuration:

enter image description here

Apparently I am missing something because the following errors appear when I am trying to compile. Can you please help? Please note that I am an amateur.

enter image description here

  • Miktex needs to find its binaries too (e.g. to create binary or a tfm). So you should better start texmaker from the miktex terminal, so that all the binaries are in the path (and then you can remove all the absolute pathes in the texmaker configuration.) – Ulrike Fischer Feb 28 at 19:13
  • @UlrikeFischer Thank you for your message. Can you please inform me how I can do that? – Whitebeard13 Feb 28 at 20:36
  • miktex.org/howto/portable-edition, click on the terminal entry and then run texmaker from there (if it is in your path simply try to type texmaker and hit enter, but I have neither the portable version available nor texmaker to test). – Ulrike Fischer Feb 28 at 20:44
1

With a portable install it is more important that a normal install to understand how the variety of paths and their priorities work.
IF you have a portable drive set to Q: this time, it could the next time be any drive from A: to Z: when you re-plug it in to your or anyone else's system.

To allow for that issue you need a self configuring start-up script. Use notepad to save the script below as for example NikitasMiktex.cmd and keep it anywhere convenient on the portable drive. Since it is written to work relative to the drive root (%~d0) it will not work on the main drive without many additional changes to test what the drive letter is.

If you move or rename the folders on the portable drive you would need to edit this file to change the folder names.
I would suggest you first rename miktex-portable-2.9.6942 now to just portable (it will no longer be version 2.9.6 since within days it will be 2.9.7 etc.)

set PATH=%~d0\Nikitas\tools\MikTex\portable\texmfs\install\miktex\bin;%PATH%  
%~d0\Nikitas\tools\MikTex\portable\texmfs\install\miktex\bin\miktex-console.exe" --hide --mkmaps  
pause  
%~d0\Nikitas\tools\TeXmaker\TeXmaker.exe "%1"  

NOTE the %1 at the end allows you to drag and drop a tex file onto this cmd file where the path is set automatically prior to running the console.

The console does not need to run however it is the key to a good stable install since it will check the path and font mapping each time you start running your TeX distribution.

The pause between console and calling Texmaker is so you can do updates and other maintenance tasks in the console without Texmaker locking out MiKTeX from updating / downloading critical files. It only takes a second to hit any key to continue but it stops to give you that chance to make adjustments each time you start.

The last line I have to guess you may have Texmaker on the same drive, but if it is on the main C: drive (in a programs folder ?) you will need to change it to the correct location

There are many refinements and additions possible but this should get you up and running.

When you run it the first time on any machine you need to PAUSE and change the MiKTeX-console Settings > second tab > Directories whenever they may be wrong for that system. They SHOULD self configure but you do need to check. while your in there it is MOST IMPORTANT that you run TASKS Update filename database to ensure that it is rebuilt for that new configuration.

Now in the console you can run the supplied TeXworks Editor OR the Terminal or simply MINIMIZE (Keep MiKTeX-console running minimised in the toolbar) and "unpause" the black window to start up Texmaker.

Now that the paths to MiKTeX are set Texmaker should be able to use that new configuration until you eventually close MiKTeX. Note that the long MiKTeX paths up to the word bin\ in your screen shot are now not needed and thefirst one should start with latex.exe -intera.... and you can alter any others with that long MiKTeX path to bin\ in the same way

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.