0

Somebody can help me briefly why I can't create German letters like ä, ö, ü etc. when creating a document. This only works if I write the letters in this way: \"a, \"o ...

I use a Mac and Texmaker as my LaTeX editor and I use a template from this site especially the "Stylish Article".

I've already changed this in the class:

\RequirePackage[applemac]{inputenc}
\RequirePackage[ngerman]{babel}
\RequirePackage[T1]{fontenc}
  • 6
    Welcome to TeX.SX! applemac? Have you tried using utf8 instead? – Phelype Oleinik Mar 1 at 22:33
  • 2
    The template you've linked uses \RequirePackage[utf8]{inputenc} and should just work on a mac in german. Why did you change the setting to applemac? – DG' Mar 1 at 22:57
  • Which editor do you use? – Bernard Mar 1 at 23:00
  • applemac is the encoding used on classic mac computers. OS X uses utf8 and basically all editors default to this. – Daniel Mar 1 at 23:07
  • I’d recommend writing new documents for LuaLaTeX and XeLaTeX and using the fontspec package rather than fontenc/inputenc. This natively supports Unicode and lets you use any font on your system. – Davislor Mar 1 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.