1

I am using biblatex with the added feature of adding all cited references to their own category:

\DeclareBibliographyCategory{cited}
\AtEveryCitekey{\addtocategory{cited}{\thefield{entrykey}}}

as shown here. Now consider this MWE:

\documentclass{scrreprt}

\usepackage[refsegment=chapter]{biblatex}
    \DeclareBibliographyCategory{cited}%so we can access all non-cited as own category
    \AtEveryCitekey{\addtocategory{cited}{\thefield{entrykey}}}

\begin{filecontents}{thebib.bib}
@misc{mathworks_constant_2018,
    type = {Documentation},
    title = {Constant volume pneumatic chamber based on ideal gas law},
    url = {https://uk.mathworks.com/help/physmod/simscape/ref/constantvolumepneumaticchamber.html},
    urldate = {2022-01-01},
    journal = {Mathworks Simulink Documentation},
    author = {{Mathworks}},
    year = {2018},
}
@online{WinNT,
  author = {MultiMedia LLC},
  title = {{MS Windows NT} Kernel Description},
  year = 1999,
  url = {http://web.archive.org/web/20080207010024/http://www.808multimedia.com/winnt/kernel.htm},
  urldate = {2010-09-30}
}
\end{filecontents}
\addbibresource{thebib.bib}

\usepackage{cleveref}

\begin{document}
    \chapter{This is a chapter}
    \autocite{mathworks_constant_2018}
    \endrefsegment%anything after not in any segment -> not printed by bibbysegment
    \nocite{*}%
    \printbibheading%print big heading once
    \defbibheading{subbibliography}{\vspace*{1.5\baselineskip}\section*{\Cref{refsegment:\therefsection\therefsegment}}}%
    \bibbysegment[heading=subbibliography]%cycle through all segments and print
    \defbibheading{notcited}{\section*{Further Reading}}
    \printbibliography[notcategory=cited, heading=notcited]
\end{document}

with an example inspired in parts by this question.

The \defbibheading with cleveref is a redefinition to allow clickable links. It is not part of the example, but I left it in so nothings breaks. I left hyperref out so they don't show. The result is:

enter image description here

Is there a way to remove citation keys – in this case [1] – from the Further Reading section?

Since no entries there are cited anywhere, we do not need citation keys there. It is just meant as a list for anyone who cares.

1

You can define a new bibliography environment for the further reading section. I just copied the definition from authoryear.bbx as that gives a reasonably pleasant result. You will also want to use the option defernumbers to make sure that the numbering comes out as expected (you could also add the option omitnumbers to the \printbibliography command of the further reading section, though that would not change the output here; there would only be a difference if further reading is followed by another numbered \printbibliography with entries that have not appeared before).

\documentclass{report}

\usepackage[refsegment=chapter, defernumbers=true]{biblatex}
\usepackage{cleveref}

\DeclareBibliographyCategory{cited}
\AtEveryCitekey{\addtocategory{cited}{\thefield{entrykey}}}

\defbibheading{subbibliography}{%
  \section*{\Cref{refsegment:\therefsection\therefsegment}}}

\defbibheading{notcited}{\section*{Further Reading}}

\defbibenvironment{bibnonum}
  {\list
     {}
     {\setlength{\leftmargin}{\bibhang}%
      \setlength{\itemindent}{-\leftmargin}%
      \setlength{\itemsep}{\bibitemsep}%
      \setlength{\parsep}{\bibparsep}}}
  {\endlist}
  {\item}

\begin{filecontents}{\jobname.bib}
@misc{mathworks_constant_2018,
  type    = {Documentation},
  title   = {Constant volume pneumatic chamber based on ideal gas law},
  url     = {https://uk.mathworks.com/help/physmod/simscape/ref/constantvolumepneumaticchamber.html},
  urldate = {2022-01-01},
  journal = {Mathworks Simulink Documentation},
  author  = {{Mathworks}},
  year    = {2018},
}
@online{WinNT,
  author  = {MultiMedia LLC},
  title   = {{MS Windows NT} Kernel Description},
  year    = 1999,
  url     = {http://web.archive.org/web/20080207010024/http://www.808multimedia.com/winnt/kernel.htm},
  urldate = {2010-09-30}
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
  \chapter{This is a chapter}
  \autocite{mathworks_constant_2018}

  \endrefsegment
  \nocite{*}
  \printbibheading
  \bibbysegment[heading=subbibliography]
  \printbibliography[notcategory=cited, env=bibnonum, heading=notcited]
\end{document}

Bibliography for Chapter 1 with numbers. Further reading without numbers.

I had to use report instead of scrreprt because of https://github.com/plk/biblatex/issues/857 to make the MWE work for me. I also removed the \vspace*{1.5\baselineskip}% for the MWE as I wanted to avoid the excessive space it introduces with the standard class.

  • This is very nice, thank you. The indentation for the second line is very nice and important for legibility. I do not have to use defernumbers, because I am not on a numeric style for the real document. Thank you for the tip. Further, I could run scrreprt successfully. Note that I am using refsegment=chapter, not refsection=chapter. Removing \vspace is a good touch I had overlooked but now adopted. – Hans Lollo Mar 3 at 16:19
  • 1
    @HansLollo For non-numeric styles the defernumbers is indeed not relevant or necessary. You are probably using an older version of biblatex or KOMA script if you don't get the undesirable behaviour (so my advise is: Don't update your system right now!), it is structurally the same issue for the refsegment and refsection option. – moewe Mar 3 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.