2

Sorry for the message in french, I'm starting again my question. I have a problem with page number. Even if I use the command : \pagestyle{empty} my first page keep a number but not the others. I don't understand where is my error. Thanks for help

\documentclass[svgnames]{article}

\usepackage[french]{babel}
\usepackage[utf8x]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage[colorinlistoftodos]{todonotes}
\usepackage{glossaries}
\usepackage{fancyhdr}
\usepackage{appendix}
\usepackage{svg}
\usepackage{ulem}
\usepackage{hyperref}
\usepackage[absolute,overlay]{textpos}
\usepackage{enumitem}
\usepackage[12pt]{extsizes}
\usepackage{pifont}
\usepackage{transparent}
\usepackage{eso-pic}

\title{Title}
\usepackage{float}
\restylefloat{figure}
\newcommand{\HRule}{\rule{\linewidth}{0.5mm}}
\pagestyle{empty}
\renewcommand{\headrulewidth}{1pt}
\renewcommand{\footrulewidth}{1pt}
%\fancyfoot[R]{\includegraphics[scale=.15]{miashs}}

\usepackage[most]{tcolorbox}
\tcbset{
        frame code={}
        center title,
        left=0pt,
        right=0pt,
        top=0pt,
        bottom=0pt,
        colback=PowderBlue!50,
        colframe=white,
        width=\dimexpr\textwidth\relax,
        enlarge left by=0mm,
        boxsep=5pt,
        arc=0pt,outer arc=0pt,
}

\begin{document}

\maketitle

\begin{textblock*}{\paperwidth}(0cm,12cm)
    \begin{tcolorbox}
        Blablabla
    \end{tcolorbox}
\end{textblock*}

\newpage
blablabla


\end{document}
  • 2
    If you feel more comfortable asking in French I suggest you have a look at texnique.fr/osqa. The site has the same general system as TeX.SX, but it is in French. Here the lingua franca is English and questions should be asked (and will be answered) in English. – moewe Mar 4 at 14:28
  • 2
    sorry i started again and thanks for the informations – AlexiaB. Mar 4 at 14:36
1

Adding thispagestyle{empty} just after \maketitle, and pagestyle{plain} after \newpage works.

Edit: as @Mico pointed in a comment, removing \pagestyle{empty} from the preamble makes adding \pagestyle{...} after \newpage unneeded.

Unrelated: the hyperref package should be loaded as the last package, with very few exceptions (mainly cleveref). Also, the language options of babel should be loaded as \documentclass options, so that all packages which are language-aware be informed.

So the code should now be this:

\documentclass[svgnames]{article}

\usepackage[french]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage{graphicx}
\usepackage[colorinlistoftodos]{todonotes}
\usepackage{glossaries}
\usepackage{fancyhdr}
\usepackage{appendix}
\usepackage{svg}
\usepackage{ulem}
\usepackage[absolute,overlay]{textpos}
\usepackage{enumitem}
\usepackage[12pt]{extsizes}
\usepackage{pifont}
\usepackage{transparent}
\usepackage{eso-pic}

\title{Title}
\usepackage{float}
\restylefloat{figure}
\newcommand{\HRule}{\rule{\linewidth}{0.5mm}}
\renewcommand{\headrulewidth}{1pt}
\renewcommand{\footrulewidth}{1pt}
%\fancyfoot[R]{\includegraphics[scale=.15]{miashs}}

\usepackage[most]{tcolorbox}
\tcbset{
    frame code={}
    center title,
    left=0pt,
    right=0pt,
    top=0pt,
    bottom=0pt,
    colback=PowderBlue!50,
    colframe=white,
    width=\dimexpr\textwidth\relax,
    enlarge left by=0mm,
    boxsep=5pt,
    arc=0pt,outer arc=0pt,
    }
    } 

\usepackage{hyperref}

\begin{document}

\maketitle
\thispagestyle{empty}
\begin{textblock*}{\paperwidth}(0cm,12cm)
\begin{tcolorbox}
    Blablabla
\end{tcolorbox}
\end{textblock*}

\newpage
 blablabla

\end{document} 

If you want page numbering to start at the first numbered page, add \pagenumbering{arabic} (or whatever style you want) jus after \newpage to reset the page counter.

  • It's right i can keep all my commands with this solution . thanks for help – AlexiaB. Mar 4 at 15:05
  • You're welcome! I suggest you take a look at the possibilities of the titling package, which greatly helps customising titkle pages. – Bernard Mar 4 at 15:08
  • Great, I will explore it, thanks again ! – AlexiaB. Mar 4 at 15:14
  • @Mico: I didn't notice it, in the O.P.'s code. I wondered why \thispagestyle{empty} seemed to act like \pagestyle{empty}. I'll edit my answer (with credits, of course). Thanks! – Bernard Mar 4 at 15:41
1

With \documentclass[svgnames,titlepage]{article} you get the titlepage witout a number. Then you can choose your pagestyle with something like.

…
\maketitle
\pagestyle{plain}
…
  • I've learnt something! I had completely forgotten this option. – Bernard Mar 4 at 14:52
  • Thanks, it's a good solution but in my report i have lot of commands to customize my first page and with this command i cannot do this. Thanks for help – AlexiaB. Mar 4 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.