3

While writing a paper about a card game I come across An experimental LaTeX Poker Package, which allows cards symbols. It looks perfect for my needs.

However when adding \usepackage{poker} I get the following error:

LaTeX Error: File `poker.sty' not found. The compiler cannot find the file you want to include. Make sure that you have uploaded the file and specified the file location correctly.

A follow-up question:

After following your advices, I placed pst-poker.sty in the Overleaf folder and used \usepackage{pst-poker}, however, when I write \Qh, \Ks, \fiveh, \ninec I get enter image description here

Solved:

As stated at Getting pst-poker to work, I had to change Overleaf's compiler to XeLaTeX, this is done at: Menu > Settings > Compiler.

Note: ArXiv do not accept XeLaTeX-compile-papers. I had to remove that package and change to a pdfLatex compiler before submitting to arXiv.

enter image description here

6
  • 1
    Try download this and upload it on your project: web.mit.edu/foley/games/Arcadia/sr/poker/poker.sty – koleygr Mar 6 '19 at 13:46
  • 4
    Note that there is a later package called pst-poker which is based on the package you found, and this newer package is on CTAN. – Marijn Mar 6 '19 at 13:53
  • Can you post the full code that gives you this? Then I can try what comes out on my my PC. – sheß Mar 6 '19 at 23:35
  • Sounds a bit as if you only copied the sty-file, but not the auxiliary files (images) as suggested by @Marjin's comment under my answer. But wihtout a MWE it's hard to tell for us. If the follow-up question begins to evolve into it's own question, please consider opening a new question. – sheß Mar 7 '19 at 8:38
  • 1
    I stand corrected. Your follow-up question is a duplicate of this: tex.stackexchange.com/questions/420242/… – sheß Mar 7 '19 at 8:54
2

Overleaf uses TeX Live 2016 (https://www.overleaf.com/learn/how-to/What_packages_do_you_support%3F). The poker package is not part of TeX Live 2016

But you can upload any packages to overleaf as part of your project (How to add a package in overleaf).

For this you'd need to download the.sty-file as suggested by @koleygr, from web.mit.edu/foley/games/Arcadia/sr/poker/poker.sty and place it in the right folder in your Overleaf project

4
  • It looks like they are upgrading: tex.stackexchange.com/questions/477874/… – Phelype Oleinik Mar 6 '19 at 13:49
  • Good to know. Though this is not going to affect the (non-)availability of poker.sty. Is it? – sheß Mar 6 '19 at 13:51
  • 2
    Probably not, as neither TeXLive 2018 has it. However it looks like pst-poker was introduced in 2017 :) (oh, Marijn just said that :) – Phelype Oleinik Mar 6 '19 at 13:54
  • 2
    Note that poker.sty loads some images for the playing cards, so you need those files as well. You can probably get those images from pst-poker, and use them with poker.sty, since the pst-poker is based on poker.sty. – Marijn Mar 6 '19 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.