1

I have created a few LyX files using 2.3.1 that are identical in their document settings, and yet, when I hit Ctrl + R, some files are processed to completion and throw up a pdf in Acrobat Reader DC, while others are processed to completion and do not appear in Acrobat. When a pdf file is not generated, I get the following messages at the end:

22:16:29.114: output file: C:/Users/UserName/AppData/Local/Temp/lyx_tmpdir.ljKjwYrYaULg/lyx_tmpbuf2/FileName.tex 22:16:29.115: 22:16:29.161: pdfview "FileName.pdf" 22:16:29.163: Successful preview of format: PDF (pdflatex)

I can if I wish, to to File > Export > Export As ... and save a pdf file, but I would prefer that it come up automatically in Acrobat. Has anyone experienced this problem? If so, what is the solution?

Thanks in advance

Thomas Philips

3
  • you have masked your username thus guess FileName.pdf is not exact there are several possibilities based on filename with spaces punctuation utf-8 characters accents etc so watch what filenames you are having the issue with secondly acrobat notoriously locks you out of a second run since the first.pdf is still open many TeX editors other than lyx run a close file before open is there a similar choice buried in your lyx configuration I don't see any acrobat related settings in Preferences Output general pdf command just those for sumatraPDF Okular Evince e.g. those that support reopening files
    – user170109
    Mar 7, 2019 at 23:02
  • Actually found acrobat is treated as a special case and they use the pdfclose/open tools so if setting is auto its not using acrobat script but if its acrobat then it must be pdfview not auto 1) Open LyX/Tools/Preferences.../File Handling/File Formats 2) Change Format to "PDF (pdflatex)" 3) Check or Change "Viewer/Custom" to "pdfview" this was an on/off problem for various viewer combinations as logged under lyx.org/trac/ticket/9961
    – user170109
    Mar 7, 2019 at 23:37
  • (Apologies I don't have high enought reputation to provide a comment) I had the same issue today and I fixed by choosing PDF(pdflatex) in the field "Format" and then choosing "Custom" as Viewer with the option auto. The latter option is crucial and circumvents the need to know the right .exe file name for the respective Viewer you are using. See a screenshot below. ![enter image description here](i.sstatic.net/QGifS.png)
    – Avocaddo
    Dec 10, 2023 at 13:06

2 Answers 2

2

Bingo! KJO's answer has solved my problem. My username is trivial (only letters no spaces), so that wasn't it. The answer lay in Tools>Preferences>File Handling>File Formats.

The default format was BibTex (I have no idea why) so I changed it to PDF(pdflatex) and then chose AcroRd32 as my Viewer, hit Save and it now works like a charm. Interestingly, if I choose pdfview as the Viewer, both the Save and Apply buttons are greyed out.

Thanks a mill!

Thomas Philips

2
  • Glad its sorted give yourself an accepted answer
    – user170109
    Mar 8, 2019 at 1:48
  • Easy mistake to make, I almost made it, but the dropdown menu that originally was on bibtex isn't setting anything, it's just a way to choose which format you want to change the settings for. So the save/apply buttons were greyed out because before changing the viewer, you hadn't actually changed anything. Bibtex was selected by default because it's first in the alphabetical list.
    – lukeuser
    May 5, 2021 at 13:02
1

Have you checked if Acrobat is your default pdf viewer; if not, make that. Reopen Lyx and under Tool bar, see Preferences then Path and then PATH Prefix. Change the path of Ghostscript to Acrobat path. Apply and then Save

1
  • Good point - I do indeed have the folder containing AcroRd32.exe in my path prefix. The weird thing is that it works for some files but not for others. Mar 7, 2019 at 14:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .