2

I have a table that is in scriptsize and when compile my code numbers itself at 2.2 instead of 2.1. It is intended for my second chapter. Does anyone know what I should do to start numbering this table at 2.1?

Thanks in advance!

\begin{table}[h]
    \centering
    \scriptsize
    \label{table:2.1}
\setlength{\extrarowheight}{2pt}
    \captionsetup{skip=0.5\baselineskip,size=scriptsize}
     \caption{An overview of meta-competences that enable engineering students to solve the future challenge, based on \shortcite{Siddique2013}}
    \begin{tabular}{ l | l }
    \textbf{Dim.} & \textbf{Description} \\
    \midrule
    \textbf{MC1} & \textbf{The ability to manage information} \\
    \midrule
    MC1.1 & To gather, interpret, validate and use information \\
    MC1.2 & Understand and use quantitative and qualitative information \\
    MC1.3 & Discard useless information \\
    \midrule
    \textbf{MC2} & \textbf{The ability to manage thinking} \\
    \midrule
    MC2.1 & Ability to identify and manage dilemmas associated with the realization of complex, \\ & sustainable, socio-techno eco-systems \\
    MC2.2 & Ability to think across disciplines \\
    MC2.3 & Holistic thinking, conceptual thinking and switching from divergent and convergent thinking \\
    MC2.4 & Ability to speculate and to identify research topics worthy of investigation \\
    MC2.5 & Ability to engage in critical discussion  \\
    MC2.6 & Identify and explore opportunities for developing break-through products, systems or services \\
    MC2.7 & Ability to think strategically by using both theory and methods \\
    \midrule
    \textbf{MC3} & \textbf{The ability to manage collaboration} \\
    \midrule
    MC3.1 & Ability to manage the collaboration process in local and global settings \\
    MC3.2 & Ability to create new knowledge collaboratively in a diverse team \\
    MC3.3 & Competence in negotiation \\
    MC3.4 & Teamwork competence \\
    \midrule
    \textbf{MC4} & \textbf{The ability to manage learning} \\
    \midrule
    MC4.1 & Ability to identify the competencies and meta-competencies needed to create value in the engineering world  \\
    MC4.2 & Ability to self-instruct and self-monitor learning \\
    MC4.3 & Ability to interact with multiple modes of learning \\
    MC4.4 &  Ability to manage a lifetime of learning or lifelong learning \\
    \midrule
    \textbf{MC5} & \textbf{The ability to manage attitude} \\
    \midrule
    MC5.1 & Ability to self-motivate  \\
    MC5.2 & Ability to cope with chaos \\
    MC5.3 & Ability to identify and acknowledge mistakes and unproductive paths;  \\
    MC5.4 & Ability to assess and manage risk taking \\
    \bottomrule

\end{tabular}
\end{table}
5
  • 4
    Not the issue, but a general advice: I'd not label your table 2:1 with \label{tabel:2.1}, instead I'd choose something that can't change even if the order of your document should change in the future, something like \label{tab:metacompetence}. Also you must use \label after the \caption or (even better) inside the mandatory argument of the \caption macro.
    – Skillmon
    Commented Mar 9, 2019 at 12:54
  • 1
    My best guess is what Skillmon suggests at the end: \label should come after \caption. Currently \label picks up the last counter that was stepped up before the table (that might be a subsection or section counter or something else entirely). See also tex.stackexchange.com/q/32325/35864, tex.stackexchange.com/q/7/35864
    – moewe
    Commented Mar 9, 2019 at 13:06
  • That's good advice guys, noted! However, when I put my label after my caption, the entire caption disappears. When I remove the \shortcite{Siddique2013} it also does not work.
    – Christiaan
    Commented Mar 9, 2019 at 13:30
  • 1
    \label has to be after (or better, in)` \caption or can not work, but for your main question, post a small complete document that shows the problem. Currently you are including a large tabular that has no effect on the numbering, but are not including any code from earlier in the document that has set the counter to the wrong value, so it is hard to offer any help. Commented Mar 9, 2019 at 13:41
  • Please tell us (a) which document class you employ and (b) which LaTeX packages you load (and with which options).
    – Mico
    Commented Mar 9, 2019 at 15:17

1 Answer 1

1

I had a similar issue when using tabularx inside a table environment, and some other people did so as well. While we can't know for certain without knowledge of OPs document class and preamble, this could be the same effect caused by an interaction with the longtable package.

As a mitigation (this does not solve the actual problem), you can manually decrease the table counter like this:

\begin{table}
  % Manually decrease table counter to mitigate a bug with tabularx loading
  % longtable and skipping uneven table numbers.
  \addtocounter{table}{-1}
  \begin{tabularx}{\textwidth}{lYY}
    % your table content
  \end{tabularx}
\end{table}

This fix was described in this answer of leandriis.

Not the answer you're looking for? Browse other questions tagged .