1

I am using Texmaker on Mac to compile some scripts. The same scripts work on other Mac computers but not mine: when I click on Quick build, it says

Could not start the command.
pdflatex -synctex=1 -interaction=nonstopmode %.tex

So the PDF file does not update.

I have searched online, and see some answers recommending to change the command preferences. However, the preferences in my system doesn't seem wrong:

enter image description here

Also, after I click on Quick build, Texmaker doesn't generate other files as it does on other computers. That is, I still only have the .tex file in the folder.

Could anyone help me with this? What should I change?

Thank you very much!

  • 1
    Just some thoughts. Are the settings on the different mac's identical? Did you install a LaTeX distribution on the system where the compilation fails? In case the it is installed is e.g. the program pdflatex available in the path? Did you start TexMaker by means of a "double click"? In the later case did you relogin after installing LaTeX? – albert Mar 9 at 15:12
  • Is MacTeX installed on your computer? Installing TeXmaker does not imply that MacTeX is installed... – Mico Mar 9 at 15:15
  • @albert Thank you for the fast reply! The settings are the same, and I just re-installed the Texmaker on this laptop where the compilation fails. What do you mean by "the program pdflatex available in the path?" Yes, I start TexMaker by double clicking the .tex file. I don't think it asks me to login..? – Tian Mar 9 at 15:16
  • @Mico I don't have MacTex...but the other laptop doesn't have it either... Is this why it fails? – Tian Mar 9 at 15:17
  • 1
    @Tian You have to reinstall Texmaker after the installation of MacTeX. – user156344 Mar 9 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.