0

How do I prevent from new page after the title at KOMA-script book?
After the title it's make a new page.

Can I prevent from it?

(I'm using LyX)

Thank you!

:: Edit ::
Here is MWE:

% Preview source code

%% LyX 2.3.2-2 created this file.  For more info, see http://www.lyx.org/.
%% Do not edit unless you really know what you are doing.
\documentclass[a4paper,oneside,english,hebrew,titlepage=false,numbers=noenddot]{scrbook}
\usepackage{fontspec}
\setcounter{secnumdepth}{3}
\setcounter{tocdepth}{3}
\setlength{\parindent}{0bp}

\makeatletter

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% LyX specific LaTeX commands.
\pdfpageheight\paperheight
\pdfpagewidth\paperwidth


\@ifundefined{date}{}{\date{}}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% User specified LaTeX commands.
\newfontfamily\hebrewfont[Script=Hebrew]{David CLM}
\newfontfamily\hebrewfonttt[Script=Hebrew]{Miriam Mono CLM}
\newfontfamily\hebrewfontsf[Script=Hebrew]{Simple CLM}
\AtBeginDocument{
\renewcommand\footnoterule{%
  \kern -3pt
  \hbox to \textwidth{\hfill\vrule height 0.4pt width .4\textwidth}
  \kern 2.6pt
}}
\renewcommand{\labelenumii}{\labelenumi\arabic{enumii}.}
\addtokomafont{disposition}{\rmfamily}
\KOMAoptions{titlepage=false}

\makeatother

\usepackage{polyglossia}
\setdefaultlanguage{hebrew}
\setotherlanguage{english}
\begin{document}
\title{\begin{english}[variant=american]%
ABC
\end{english}}%
\maketitle

\chapter{ABC}

abc
\end{document}
  • If you want an in-page title (aka title head) use option titlepage=false as documented in the KOMA-Script manual. But for book, I would not recommend to do so. – Schweinebacke Mar 12 at 11:55
  • I would not recommend to use scrbook for documents, that should not start a new page for each chapter. Use scrartcl instead and sections instead of chapters. – Schweinebacke Mar 12 at 11:56
  • Which benefits do you like to use, that are not provided by scrartcl? – Schweinebacke Mar 12 at 11:57
  • @Schweinebacke - the chapters, and all the levels the book suggesting me :-) – heblyx Mar 12 at 11:58
  • @Schweinebacke, you right and I edited my question... – heblyx Mar 12 at 11:59
1

See the KOMA-Script manual:

screenshot from the KOMA-Script manual

So you just need to set option titlepage=false to produce a in-page title with scrbook, e.g.:

\documentclass[titlepage=false]{scrbook}
\begin{document}
\title{Title}
\author{Schweinebacke}
\maketitle
And here comes additional text.
\end{document}

in-page title with scrbook

As also explained in the KOMA-Script manual, you can set the option not only with \documentclass but also using \KOMAoptions:

\documentclass{scrbook}
\KOMAoptions{titlepage=false}
\begin{document}
\title{Title}
\author{Schweinebacke}
\maketitle
And here comes additional text.
\end{document}

Same result.

But note: This does not prevent, e.g., \chapter from starting a new page, if it follows \maketitle. And note, \tableofcontents etc. also use \chapter (or \chapter* or \addchap).

Private note: In my opinion it does not make any sense to use scrbook with an in-page title. Books should always use title pages. So I'm even astonished that book classes provide in-page titles.

  • I need to put it at "class options"? Thank you! – heblyx Mar 12 at 12:10
  • Do you know how to do it at LyX? At class options it's doesn't work.... :-( – heblyx Mar 12 at 12:13
  • Maybe LyX shares my opinion. Or maybe there is an option titlepage somewhere in the document settings. I never use LyX, sorry. But maybe \KOMAoptions does work. – Schweinebacke Mar 12 at 12:16
  • This is what I tried but it's don't work :-( – heblyx Mar 12 at 12:28
  • 1
    @heblyx This line is ok. Have a look at the LaTeX code that LyX produces. BTW: \KOMAoptions can be used even after \begin{document}. This would not be good practice, but the code of LyX often is not best practice too. BTW: Such problems are one reason, why you always should add a MWE to your question. – Schweinebacke Mar 12 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.