This bug in MiKTeX is fixed as of 29. March 2012.

I looked briefly at the LuaTeX documenation but could not find any information whether LuaTeX has a problem with special characters in path names. Is this a known bug?

My minimal example looks like this:


test test test test 



The document compiles nicely with pdfTeX (used to create test2.pdf) but when I run the same file with LuaTeX I get the following error message:

!LuaTeX error (file test2.pdf): PDF inclusion: could not stat() file 'C:/Temp/U mlautÄ/test2.pdf'

The correct path is C:\temp\UmlautÄ and it seems as if LuaTeX (from current MikTeX 2.9) can not handle this correctly. Is this a bug? How can I work around this if my profile path contains an umlaut?

Edit: I tried \usepackage[utf8]{luainputenc} and \usepackage[encoding,filenameencoding=utf8]{grffile}, both did not change the situation (the source file is UTF8 encoded).

  • 1
    This does not happen with TeXlive/Mac OS X. But this needs to be fixed.
    – topskip
    Mar 13, 2012 at 21:38
  • Try adding \usepackage[encoding,filenameencoding=utf8]{grffile}
    – egreg
    Mar 13, 2012 at 21:57
  • It fails here, too, with MiKTex 2.9. Maybe, it’s a specific problem of the Lua(La)TeX version: The log file tells me, I have “LuaTeX, Version beta-0.70.1-2011080216 (rev 4277)” installed. In TeXLive there is a newer version, or not? For you, Alexander, the only workaround, I think, will be to avoid non-ASCII characters in the path.
    – Speravir
    Mar 14, 2012 at 0:02
  • 2
    I can reproduce the problem and have made a bug report at the miktex bug tracker. But I strongly advice you to avoid non-ascii chars (and if possible spaces) in folder and file names. The time spend to get around the regularly arising problems can be used for better things. Mar 14, 2012 at 9:02
  • 2
    @UlrikeFischer: Thank you for reporting it. To avoid non-ascii chars is not always possible, e.g. some company file server use \\servername\groupname\lastname as the home directory and if the name contains an umlaut the user has to deal it.
    – Alexander
    Mar 14, 2012 at 10:39

1 Answer 1


According to Christian Schenk the bug has been resolved by the latest update (I haven't the time to test it).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .