0

I'm trying to edit this overleaf template: https://www.overleaf.com/latex/templates/a-customised-curve-cv/mvmbhkwsnmwv

In particular I want to completely remove the label date from the bibliography items, since it does not suit my field.

Surname N. (2019). A nice paper. -->> Surname N.. A nice paper.

I concentrated most of my effort in the setting.sty file, where alle the packages are loaded.

Disclaimer: I need to stick with the apa style otherwise the whole bibliography template breaks down.

I tried every solution I found (~2 hours of failures) before coming here as a last resort.

I tried to add at the already existing

\AtEveryBibitem{\makebox[2.5em][l]{\circled{\thebibitem}\stepcounter{bibitem}}
\AtEveryBibitem{\clearfield{extrayear}\clearfield{extradate}\makebox[2.5em][l]{\circled{\thebibitem}\stepcounter{bibitem}}

Without success, as any of the countless formatting solutions.

It seems that none of the field manipulation options works in this template ad I do not know why.

Can someone help me?

Thanks, Alberto

0

You can remove the year from the bibliography by redefining the relevant macro.

For the outdated version of biblatex and biblatex-apa on Overleaf you will need

\renewbibmacro*{labelyear+extrayear}{}

For more recent versions

\renewbibmacro*{labelyear+extradate}{}

should be the right command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.