0

When I run the following code (pdflatex), Command Line: pdflatex.exe --interaction=errorstopmode --synctex=1 "ex_article.tex" Startup Folder: C:\Users\wendy\Desktop\siamart_171218

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (MiKTeX 2.9) entering extended mode (C:\Users\wendy\Desktop\siamart_171218\ex_article.tex LaTeX2e <2011/06/27> Babel and hyphenation patterns for loaded.

For additional information on amsmath, use the `?' option.

Package caption Warning: Unsupported document class (or package) detected, (caption) usage of the caption package is not recommended. See the caption package documentation for explanation.

Package xr Warning: No file ex_supplement.aux LABELS NOT IMPORTED. on input line 35.

No file ex_article.aux. Package amsmath Warning: Cannot use split' here; (amsmath) trying to recover withaligned' on input line 116. LaTeX Warning: Reference sec:Pre' on page 1 undefined on input line 122. LaTeX Warning: Referencesec:Alt' on page 1 undefined on input line 122. LaTeX Warning: Reference sec:Con' on page 1 undefined on input line 122. Package amsmath Warning: Cannot usesplit' here; (amsmath) trying to recover with `aligned' on input line 155.

[3]

LaTeX Warning: Reference `eq:1' on page 1 undefined on input line 230.

Package amsmath Warning: Cannot use split' here; (amsmath) trying to recover withaligned' on input line 1321.

No file ex_article.bbl. [13] (C:\Users\wendy\Desktop\siamart_171218\ex_article.aux)

gbk2uni, version 0.22, initially implemented by cxterm and ZLB in Jan. 2003 enhanced by hooklee in Mar. 2003. please visit www.ctex.org and www.chinatex.org for more information. gbk2uni ex_article.out is finished!


PDFLaTeX Compilation Report (Pages: 13)

Errors: 0 Warnings: 20 Bad Boxes: 5


That's all.

What I get is:

We present some preliminaries in ??.

Even I can get the PDF . I guess if the cleveref.sty is too old to support the command \cref ? But I can't find the new cleveref.sty in the official website. And does it have the relationship with a fact that I delete the ex_article.aux every time. If not, I will get the following message and can't get the pdf.

Don't delete the .aux:

...thod of multipliers\relax}{equation.9}{}}

The original code is:

\documentclass[review,onefignum,onetabnum]{siamart171218}
\usepackage{mathrsfs}
\usepackage{subfig}
\input{ex_shared}
\ifpdf
\hypersetup{
  pdftitle={matrix information},
  pdfauthor={Wen}
}
\fi
\externaldocument{ex_supplement}

\begin{document}
\section{Introduction}

\label{sec:Int}
The paper is organized as follows. We present some preliminaries in \cref{sec:Int}. 

\end{document}
  • To make sure that cross references appear as intended LaTeX needs to be run at least twice. On the first run the reference will only be marked as ??. I don't have siamart171218 installed at the moment, so I can not test, but assuming cleveref is loaded by the class and there are no other errors, the example should compile fine. After a second LaTeX run the \ref should show just fine. Did you run LaTeX at least twice? – moewe Mar 15 at 11:55
  • Yes, I have. But no helpful.... – wendy Mar 15 at 11:56
  • Are there any errors or warnings after the second run? I downloaded all the files from siam.org/Publications/Journals/About-SIAM-Journals/…, put them in the same folder as your MWE and managed to produce the desired output after running LaTeX twice. – moewe Mar 15 at 12:04
  • 3
    The .aux file is needed for the references to show properly. If you delete it, you will always get ?? in the output instead of the correct reference (see tex.stackexchange.com/q/111280/35864 for a great explanation why that is). So I guess we should investigate why you get the error from your .aux file. Unfortunately, the error message you get when you don't delete the .aux is cut off. Can you repost it completely and add an MWE that reproduces that error, please? – moewe Mar 15 at 12:27
  • I solved this problem just now~ Don't need to delete the .aux, and input 's' in your command line window, then your code will continue to run. – wendy Mar 17 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.