1

I don't know why the footnote doesn't work. It does without \par.

\documentclass[a4paper, 12pt]{article}

\title{title%
\footnote{
    para1\par
    para2
}%
}
\author{author}

\begin{document}
\maketitle
text
\end{document}
  • Paragraphing doesn't work very well in footnotes oin general; LaTeX has defined \par to have checks that often aren't appropriate in a footnote environment. Instead of \par you can use \endgraf which does only the basic positioning, without the extra checks. – barbara beeton Mar 16 at 22:17
  • I tries an empty line for a paragraph break but also got an error message. Thanks for your help. – Max Mar 16 at 23:07
1

For why it doesn't work see: Why don't we always use \long\def instead of \def?

So to fix it, you could redefine \title and \thanks from latex.ltx to be \long which will then allow the paragraph break.

\makeatletter
\long\def\title#1{\gdef\@title{#1}}
\long\def\thanks#1{%
  \footnotemark
  \protected@xdef\@thanks{%
    \@thanks\protect\footnotetext[\the\c@footnote]{#1}}}
\makeatother

But an easier option is just to define your footnote text as a separate macro which gets around the error checking.

\documentclass[a4paper, 12pt]{article}

\def\titlefootnotetext{para1\par para2}

\title{title\thanks{\titlefootnotetext}}
\author{author}

\begin{document}
\maketitle
text
\end{document}
  • Thanks, very well answered with more than one options. I have never used \def before. – Max Mar 16 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.