0

After compilation, my documents restarts numbering after each chapter. I would like every reference number to be used only once accross the wole document.

Here are my biblatex settings:

\usepackage[backend=biber, citestyle=authoryear, hyperref=true, sorting=nty, defernumbers=true]{biblatex}

And here is the print command:

\printbibheading[
heading=bibintoc,
title={References}
]
\printbibliography[heading=subbibintoc,keyword={Secondary},title={Secondary Sources}]
\printbibliography[heading=subbibintoc,keyword={Primary},title={Primary Sources}]

edit: Here is a working example that reproduced the probelm:

Thanks a lot for taking the time to help.

Here is a small working ecample of my problem:

\documentclass[12pt,a4paper, oneside, oldfontcommands, hidelinks]{memoir}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{microtype}
\usepackage[dvips]{graphicx}
\usepackage{xcolor}
\usepackage{times}
\usepackage[export]{adjustbox}
\usepackage{geometry}
\usepackage{setspace}
\usepackage{footnotebackref}
\usepackage{hyperref}
\usepackage{tocloft}
\usepackage{blindtext}
\usepackage{etoolbox}
%\usepackage[backend=biber, style=verbose, hyperref=true, sorting=nyt]{biblatex}
\usepackage[backend=biber, citestyle=authoryear, hyperref=true, sorting=nty]{biblatex}
%\usepackage[backend=biber,authordate]{biblatex-chicago}
%\usepackage[backend=bibtex,style=verbose-trad2]{biblatex}
\addbibresource{sample.bib} 
\setlength{\absleftindent}{0pt}
\setlength{\absrightindent}{0pt}
\abstractintoc
%\setlength\cftparskip{-2pt}






% PDF VIEW
% \geometry{total={210mm,297mm},
% left=25mm,right=25mm,%
% bindingoffset=0mm, top=25mm,bottom=25mm}
% PRINT
%\geometry{total={210mm,297mm},
%left=20mm,right=20mm,
%bindingoffset=10mm, top=25mm,bottom=25mm}



\OnehalfSpacing
\linespread{1.5}

%%% CHAPTER'S STYLE
\chapterstyle{verville}


\newlength{\aftertocskip}
\setlength{\aftertocskip}{1\baselineskip}% Space after ToC title
\renewcommand{\aftertoctitle}{\par\nobreak\vskip\aftertocskip}

%%\chapterstyle{ger}
%\chapterstyle{madsen}
%\chapterstyle{ell}
%%% STYLE OF SECTIONS, SUBSECTIONS, AND SUBSUBSECTIONS
\setsecheadstyle{\Large\bfseries\sffamily\raggedright}
\setsubsecheadstyle{\large\bfseries\sffamily\raggedright}
\setsubsubsecheadstyle{\bfseries\sffamily\raggedright}


%%% STYLE OF PAGES NUMBERING
%\pagestyle{companion}\nouppercaseheads 
%\pagestyle{headings}
%\pagestyle{Ruled}
\pagestyle{plain}
\makepagestyle{plain}
\makeevenfoot{plain}{\thepage}{}{}
\makeoddfoot{plain}{}{}{\thepage}
\makeevenhead{plain}{}{}{}
\makeoddhead{plain}{}{}{}


\maxsecnumdepth{subsection} % chapters, sections, and subsections are numbered
\maxtocdepth{subsection} % chapters, sections, and subsections are in the Table of Contents


%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%

\begin{document}


    \begin{abstract}
        W
    \end{abstract}
    \clearpage
    %%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%
    %%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%---%%%

    \chapter{Introduction}
tter\footcite{Abilova2016}.nce”

    \chapter{Th}


    \begin{itemize}
        \item [--] nt"\footcite{Moe1984}.
    \end{itemize}


    \appendix


    \printbibheading[
    heading=bibintoc,
    title={References}
    ]
    \printbibliography[heading=subbibintoc,keyword={Secondary},title={Secondary Sources}]
    \printbibliography[heading=subbibintoc,keyword={Primary},title={Primary Sources}]


\end{document}

And here is the sample.bib file:

@report{Abilova2016,
  author = {Olga Abilova and Alexandra Novosseloff},
  title = {Demystifying Intelligence in UN Peace Operations: Toward an Organizational Doctrine},
  institution = {International Peace Institute},
  year = {2016},
  keywords     = {Primary}
}
@article{Moe1984,
    author    = {Terry M. Moe},
    title     = {The New Economics of Organization},
    journal   = {American Journal of Political Science},
    volume   = {28},
    %number   = "",
    pages    = {739-777},
    year      = {1984},
    %month    = "",
    %note     = "",
    keywords  = {Secondary}
}
  • 1
    I would that this general setup would result in continuous numbering, even though I find the use of citestyle=authoryear quite unusual with an otherwise numeric bibliography. Unfortunately, the code shown so far is not enough to reproduce the behaviour you are seeing. It would help us greatly if you could expand it to a full example document starting with \documentclass, the relevant bits of the preamble and a few dummy citations and what else is necessary to see the issue in \begin{document}...\end{document}, a so-called MWE: tex.meta.stackexchange.com/q/228/35864 – moewe Mar 16 at 11:16
  • Thanks a lot for taking the time. I added a working example that replicates the issue. – Pan Mar 16 at 13:05
  • Thanks for your clarifications. I made the example smaller and added a relevant bib file content. I didn't, however, touch the preamble as the problem might be there (a missing package or something else). – Pan Mar 16 at 13:37
  • Unlike the very first line of code in the question (my biblatex settings) the MWE does not use defernumbers=true any more. With defernumbers=true the numbering is as one would expect. See tex.stackexchange.com/q/333493/35864 – moewe Mar 16 at 13:41
  • 1
    cross-post: texnique.fr/osqa/questions/6334/… – user36296 Mar 16 at 19:14
2

As it turned out after a short discussion in the comments, the issue was actually the footnote numbering and had nothing to do with biblatex.

memoir (like the standard book class) restarts the numbering for footnotes in each chapter. To turn off that behaviour, add

\counterwithout{footnote}{chapter}

to the preamble. See also Continuous footnote numbering.

Be warned though that in your current setup the footnote numbers and the numbers in the bibliography have no guaranteed connection. If they coincide for some references that is purely accidental and nothing to be relied upon. In fact as it stands now, the numbers in the bibliography are not reflected anywhere in the document and hence serve no real purpose.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.