0

I am new to LaTeX and I just strated to use Polyglossia to write Hebrew documents. When I try to write text in italic, it just produces the same text style. For example

\documentclass{article}
\usepackage{fontspec}
\usepackage{polyglossia}
\setmainlanguage{hebrew}
\setmainfont{David}

\begin{document}
שלום עולם

\textit{שלום עולם}
\end{document}

Produces:

enter image description here

How can I define italic-type for the font?

  • 1
    Maybe David does not have an italic variant (or you don't have it installed). Try David CLM from culmus.sourceforge.net – David Purton Mar 16 at 13:18
  • I downloaded it using this link: ma.huji.ac.il/~sameti/tex/culmusmiktex.html for Windows, but it doesn't seem to be working... When trying to write in italic variant it just says that the file is not found.David CLM exists, but its italic variant doesn't. – ABN263 Mar 16 at 19:07
  • Italics aren't really used in hebrew typesetting. Some people do letterspacing (which I suggest against). There is a way to fake it, though. You can use the AutoFakeSlant option with a negative number when you use the font. Although that's also arguably a bad idea. – A Gold Man Mar 16 at 21:10
  • Make sure what you downloaded includes David CLM in OpenType format and it is installed as a system font so it appears in other applications (e.g., Word). – David Purton Mar 16 at 22:01
  • Actually, you definitely don't want that MikTeX download. I does not include any OpenType fonts, only formats for use with pdflatex. You want to download the latest release from SourceForge: sourceforge.net/projects/culmus/files/culmus/0.133 – David Purton Mar 16 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.