I have a dvi file from 1989 that uses special fonts. The dvi file was created from LaTeX. I saved all of the LaTeX source, all of the .tfm files, all of the .pk files, all of the .pxl files, and all of the .1500pxl files. I also saved the shell scripts that generated everything.

I'd like to convert the document to modern pdf.

The shell scripts use a command:

dvi2ps -a /tx/qobi/tex/pxlfonts -a /usr/lib/tex/pxlfonts.canon smthesisfrag

I no longer have dvi2ps. I have dvips instead. But dvips doesn't accept the -a argument. I can't figure out from the man page, the --help, or the online document what the equivalent of the -a argument is, i.e. how one specifies a directory with .pk, .pxl, and .1500pxl files.

Any ideas? Thanks

  • if it's just a one off you could simply copy them to the local directory – David Carlisle Mar 19 '19 at 16:49
  • just tried that. didn't work – Jeffrey Mark Siskind Mar 19 '19 at 17:26
  • qobi@ym>ls -l heb10.* -rw------- 1 qobi qobi 6956 Mar 19 13:22 heb10.1500pxl -rw------- 1 qobi qobi 1444 Mar 19 13:22 heb10.pk -rw------- 1 qobi qobi 6956 Mar 19 13:22 heb10.pxl -rw------- 1 qobi qobi 712 Mar 19 13:22 heb10.tfm qobi@ym>ls -l hebs10.* -rw------- 1 qobi qobi 7192 Mar 19 13:22 hebs10.1500pxl -rw------- 1 qobi qobi 1896 Mar 19 13:22 hebs10.pk -rw------- 1 qobi qobi 7192 Mar 19 13:22 hebs10.pxl -rw------- 1 qobi qobi 712 Mar 19 13:22 hebs10.tfm qobi@ym>dvips -o smthesis.ps -M smthesis.dvi – Jeffrey Mark Siskind Mar 19 '19 at 17:27
  • dvips: Font heb10 not found; using cmr10 – Jeffrey Mark Siskind Mar 19 '19 at 17:27
  • 1
    try dvips -d -1 to turn on debugging (texdoc dvips page 9) it will tell you where it is looking... – David Carlisle Mar 19 '19 at 17:49

Thanks to David Carlisle.

The simple solution is to:

  1. make a dpi300 (change resolution as appropriate) subdirectory in the directory that has the dvi file; put the .pk and .pxl files in that subdirectory
  2. run dvips with -M -X 300 -Y 300 (change resolution as appropriate)

You can figure out where dvips tries to find various files by giving it the -d -1 option as the first on the command line.

  • You can accept your answer so it drops from unanswered list (you may even get the badge :-) – user170109 Mar 20 '19 at 1:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.