0

I am new to LaTeX, and at this moment I am writing my thesis paper using Turabian style. I am trying to cite using \cite but rather than showing "(Author last name, year)" or even "[number]" it's showing me whole reference fields. I just want "(last name, year)". Example:

have been successful in finding equation \cite{einstein}

But it outputs:

have been successful in finding equation Albert Einstein, “Zur Elektrodynamik bewegter K ̈orper,” Annalen der Physik 322, no. 10 (1905):891–921. doi:http:/dx.doi.org/10.1002/andp.19053221004

In the bibliography section, it does show the reference

Einstein, Albert. “Zur Elektrodynamik bewegter K ̈orper.” Annalen der Physik 322, no. 10 (1905): 891–921. doi: http:/dx.doi.org/10.1002/andp.19053221004 .

This is what I have inside by .bib file and main.tex file

@article{einstein,
author = {Albert Einstein},
title = {Zur Elektrodynamik bewegter K{\"o}rper},
journal = {Annalen der Physik},
volume = {322},
number = {10},
pages = {891--921},
year = {1905},
DOI = {http://dx.doi.org/10.1002/andp.19053221004}
}


\usepackage[backend=biber]{biblatex-chicago}
\usepackage{bibentry}
\addbibresource{backmatter/works-cited.bib}
\printbibliography

This could be an easy fix, but since I am new to LaTex I couldn't figure out the issue. Hence, I came here for help.

  • 1
    You want \usepackage[authordate,backend=biber]{biblatex-chicago}. And probably you also want to know about \parencite and \textcite. – David Purton Mar 20 at 6:25
  • 1
    By default biblatex-chicago is in so-called note mode and prints full citations. If you want shorter author-year citations load \usepackage[authordate, backend=biber]{biblatex-chicago}. You may want to use \autocite instead of \cite. The bibentry package is not needed. – moewe Mar 20 at 6:25
  • Thanks guys, both the answers worked. – Messy Mar 21 at 3:39
  • @DavidPurton Merci. – moewe Mar 21 at 13:04
1

By default biblatex-chicago uses note style references. You need to pass it the authordate option.

Also, \cite just prints the citation, but you want it in parentheses. To do this you should either use \autocite, which puts citations in the format that makes most sense for the current biblatex style, or \parencite which forces the citation to appear in parentheses.

You may also find \textcite helpful which is designed for running text and just places the year in parentheses.

Also as an aside, biblatex prefers the date field over the year field. date allows for much more flexibility in specifying dates.

MWE

\documentclass{article}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@article{einstein,
  author = {Albert Einstein},
  title = {Zur Elektrodynamik bewegter K{\"o}rper},
  journal = {Annalen der Physik},
  volume = {322},
  number = {10},
  pages = {891-921},
  date = {1905},
  doi = {http://dx.doi.org/10.1002/andp.19053221004}
}
\end{filecontents}
\usepackage[authordate]{biblatex-chicago}
\addbibresource{\jobname.bib}
\begin{document}

\verb|\cite{einstein}|: \cite{einstein}

\verb|\autocite{einstein}|: \autocite{einstein}

\verb|\parencite{einstein}|: \parencite{einstein}

\verb|\textcite{einstein}|: \textcite{einstein}

\printbibliography
\end{document}

output

  • 1
    We could also write Zur Elektrodynamik bewegter Körper and exploit that biblatex (with Biber) can deal with Unicode. One would probably want to add langid = {german}, to the entry to preserve capitalisation in styles with sentence case. – moewe Mar 21 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.