2

I am using RevTeX4-1.

When I typeset the original file, compile the bibliography, and then try to typeset the original file again, I get an error:

"! Undefined control sequence. < argument> @bibitemShut."

Below is a minimal file with which I get the error, followed by the test .bib file that I used, and then followed by the .bbl file it outputs. Can anyone help?

(I am using PcTeX, which I purchased many years ago and no longer seems to have much support available, but which I am very used to. Perhaps this is my problem but I am hoping not, because I'd prefer not to have to get used to a whole new interface.)

I will also mention that when compiling the bibliography, I do get a warning but am guessing this is not the problem. The warning is this:

Warning--jnrlst (dependency: not reversed) set 1

merlin.mbs apsrev4-1.bst 2010-07-25 4.21a (PWD, AO, DPC) hacked

Control: key (0) 

Control: author (8) initials jnrlst

Control: editor formatted (1) identically to author

Control: production of article title (-1) disabled

Control: page (0) single

Control: year (1) truncated

Control: production of eprint (0) enabled

(There was 1 warning)

Here is my minimal tex file:

\documentclass[pra]{revtex4-1}

\begin{document}

\maketitle

Here's one citation \cite{Ref1}, and now another one \cite{Ref2}. 

\bibliography{Testrefs}

\end{document}

And here is my bib file:

@ARTICLE{Ref1,
    AUTHOR={Someone1a and Someone1b},
    TITLE={Title1},
    JOURNAL={Journal1},
    VOLUME={44},
    PAGES={5555},
    YEAR={1999}
}

@ARTICLE{Ref2,
    AUTHOR={Someone2a and Someone2b},
    TITLE={Title2},
    JOURNAL={Journal2},
    VOLUME={55},
    PAGES={7777},
    YEAR={2000}
}

In case it is useful, here is the bbl file created when I compile the bibliography:

%merlin.mbs apsrev4-1.bst 2010-07-25 4.21a (PWD, AO, DPC) hacked
%Control: key (0)
%Control: author (8) initials jnrlst
%Control: editor formatted (1) identically to author
%Control: production of article title (-1) disabled
%Control: page (0) single
%Control: year (1) truncated
%Control: production of eprint (0) enabled
\begin{thebibliography}{2}%
\makeatletter
\providecommand \@ifxundefined [1]{%
 \@ifx{#1\undefined}
}%
\providecommand \@ifnum [1]{%
 \ifnum #1\expandafter \@firstoftwo
 \else \expandafter \@secondoftwo
 \fi
}%
\providecommand \@ifx [1]{%
 \ifx #1\expandafter \@firstoftwo
 \else \expandafter \@secondoftwo
 \fi
}%
\providecommand \natexlab [1]{#1}%
\providecommand \enquote  [1]{``#1''}%
\providecommand \bibnamefont  [1]{#1}%
\providecommand \bibfnamefont [1]{#1}%
\providecommand \citenamefont [1]{#1}%
\providecommand \href@noop [0]{\@secondoftwo}%
\providecommand \href [0]{\begingroup \@sanitize@url \@href}%
\providecommand \@href[1]{\@@startlink{#1}\@@href}%
\providecommand \@@href[1]{\endgroup#1\@@endlink}%
\providecommand \@sanitize@url [0]{\catcode `\\12\catcode `\$12\catcode
  `\&12\catcode `\#12\catcode `\^12\catcode `\_12\catcode `\%12\relax}%
\providecommand \@@startlink[1]{}%
\providecommand \@@endlink[0]{}%
\providecommand \url  [0]{\begingroup\@sanitize@url \@url }%
\providecommand \@url [1]{\endgroup\@href {#1}{\urlprefix }}%
\providecommand \urlprefix  [0]{URL }%
\providecommand \Eprint [0]{\href }%
\providecommand \doibase [0]{http://dx.doi.org/}%
\providecommand \selectlanguage [0]{\@gobble}%
\providecommand \bibinfo  [0]{\@secondoftwo}%
\providecommand \bibfield  [0]{\@secondoftwo}%
\providecommand \translation [1]{[#1]}%
\providecommand \BibitemOpen [0]{}%
\providecommand \bibitemStop [0]{}%
\providecommand \bibitemNoStop [0]{.\EOS\space}%
\providecommand \EOS [0]{\spacefactor3000\relax}%
\providecommand \BibitemShut  [1]{\csname bibitem#1\endcsname}%
\let\auto@bib@innerbib\@empty
%</preamble>
\bibitem [{\citenamefont {Someone1a}\ and\ \citenamefont
  {Someone1b}(1999)}]{Ref1}%
  \BibitemOpen
  \bibfield  {author} {\bibinfo {author} {\bibnamefont {Someone1a}}\ and\
  \bibinfo {author} {\bibnamefont {Someone1b}},\ }\href@noop {} {\bibfield
  {journal} {\bibinfo  {journal} {Journal1}\ }\textbf {\bibinfo {volume}
  {44}},\ \bibinfo {pages} {5555} (\bibinfo {year} {1999})}\BibitemShut
  {NoStop}%
\bibitem [{\citenamefont {Someone2a}\ and\ \citenamefont
  {Someone2b}(2000)}]{Ref2}%
  \BibitemOpen
  \bibfield  {author} {\bibinfo {author} {\bibnamefont {Someone2a}}\ and\
  \bibinfo {author} {\bibnamefont {Someone2b}},\ }\href@noop {} {\bibfield
  {journal} {\bibinfo  {journal} {Journal2}\ }\textbf {\bibinfo {volume}
  {55}},\ \bibinfo {pages} {7777} (\bibinfo {year} {2000})}\BibitemShut
  {NoStop}%
\end{thebibliography}%
  • I have not. The reason is that while PcTeX provides info as to how to set things up to use it with revtex4-1, there is no such info with revtex4-2. So I was afraid I would be hopelessly lost trying to figure out the latter. – Scott Mar 21 at 23:13
  • Well, gosh, I solved my problem. I added the following line in the preamble, and now everything works perfectly: \newcommand{\BibitemShut}[1]{} – Scott Mar 21 at 23:39
1

Well, I do not know PcTeX and therefore I do not know which versions of packages are included there.

But after a look to there web page (copyright 2009, last update 2013; telling nothing about used package versions) I simply suggest to not use this very outdated and as it seems unsupported software. Depending on your used computer I suggest to install MiKTeX or TeXLive ...

With an current MiKTeX on Windows 8 I can compile your MWE without problems, only some warnings that revtex4-1 misses some parameter ...

Resulting pdf:

resulting pdf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.