1

UPDATE:

Added the command \PassOptionsToPackage{subfigure}{tocloft} before the easy-todo package, according to the answers, and it solved the problem! :)

I have this error when i try to use subfigure, submat package and easy-todo:

Command \c@lofdepth already defined. \newcounter{lofdepth}

I tried some of the suggestions given in other questions, however they did not work. And i really need to maintain the notes.

Does anyone can help me fix it?

Thanks in advance!

\usepackage{subfigure}
\usepackage{subfigmat}
%Quick notes.
\PassOptionsToPackage{subfigure}{tocloft} %SOLUTION - added line
\usepackage{easy-todo}
%\usepackage[disable]{easy-todo} 

\begin{document}

Text with an important note \todo{Note}.
Figure bellow:

\begin{figure}[h!]
    \centering
    \includegraphics[width=12cm,height=9cm]{Figure.JPG}
    \caption{Figure to test.}
    \label{fig:test}
\end{figure}.

\end{document}
  • 1
    Welcome to TeX.SE! Could you please add a minimal example so that we can reproduce your problem? – JouleV Mar 22 at 15:05
  • Just good guessing: When using the tocloft package you need to specifiy the option subfigure: \usepackage[subfigure]{tocloft} – Axel Sommerfeldt Mar 22 at 15:08
  • 1
    @MarianaMoreira But easy-todo uses the tocloft package. So \PassOptionsToPackage{subfigure}{tocloft} before loading the easy-todo package should help. – Axel Sommerfeldt Mar 22 at 15:13
  • @AxelSommerfeldt I didn't knew! Thank you so much! It solved the problem! – Mariana Moreira Mar 22 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.