1

I am trying to transition from a very old and no longer supported latex platform to using Miktex with texmaker. There seems to be a problem with bibtex, but actually the problem may be more than just that now, since I may have messed things up trying to fix it on my own (knowing nothing to begin with, unfortunately). At first it would build fine except it wouldn't do the bibtex at all. Thinking maybe it couldn't find my *.bib file, I put "C:/Users/cohen5/Documents/Research/Testrefs" %.aux into the Bib(la)tex command in the Configure Texmaker box. I also tried it without the "Testrefs" at the end, and also with "Testrefs.bib" at the end instead. None work. So now it will not build at all, getting the error:

Error : could not start the command : "C:/Users/cohen5/Documents/Research/Testrefs" "test".aux

I then tried uninstalling Texmaker and then reinstalled it, hoping it would reset the Bib(la)tex command to what it used to be, but no such luck.

So I guess this is two questions. (1) How do I get it back to building at all? and (2) Once it will build again, how do I get it to do the bibliography?

Here is a test file:

\documentclass[pra]{revtex4-2}
\begin{document}
\maketitle

 Here is one citation \cite{Ref1} and here is another \cite{Ref2}.

\bibliography{Testrefs}
\end{document}

P.S. I have also tried with the previous version of revtex (Revtex4-1).

Here is my Testrefs.bib file:

@ARTICLE{Ref1,
AUTHOR={Someone1a and Someone1b},
TITLE={Title1},
JOURNAL={Journal1},
VOLUME={44},
PAGES={5555},
YEAR={1999}
}
@ARTICLE{Ref2,
AUTHOR={Someone2a and Someone2b},
TITLE={Title2},
JOURNAL={Journal2},
VOLUME={55},
PAGES={7777},
YEAR={2000}
}
  • First make sure you are happy that MiKTeX is up to date, use MiKTeX-console as your launch point where you change settings or call TeXworks on the left or run console commands. When you do updates or other significant changes make sure to run the TASKS commands to refresh filename database and fonts. Put your testfile and bib file in a fresh folder and opening the testfile with Texmaker I get a good result by using the top left pulldown to select pdfLaTeX+MakeIndex+BibTeX then a click on the green arrow works as expected. It may need TWO runs on some occasions – KJO Mar 22 at 18:11
  • I just updated Miktex. I do not see Texworks on the left and don't understand what you mean by "or run console commands". I also don't know what you mean by "run the TASKS commands". I put those files in a fresh folder as you suggest, but still get the same error message. – Scott Mar 22 at 18:31
  • I meant I do not see texmaker, I did not mean to write texworks. – Scott Mar 22 at 18:39
  • Ok so I should have checked windows MiKTeX-console has TeXworks built in are you on a mac perhaps ? – KJO Mar 22 at 18:39
  • 1
    I also later discovered errors in my .bib file, which I have no idea where they came from. I'm pretty sure they didn't use to be there, they include strange characters that I am sure I never put there, so it is rather strange. Texmaker was doing other strange things, so I have changed over to using TexStudio and am very happy with using that. – Scott Mar 25 at 3:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.