3

I am having trouble using compiling argument

lualatex -shell-escape

as mentioned in this question

using arara. I cant get the right syntax, and I am failing to find it in arara user manual. I tryed both

% arara: lualatex --shell-escape

and

% arara: lualatex { shell = yes }

Gotta admit that I am not sure what those commands mean exactly. But none of them leads to successful compilation with arara. As MWE can be perfectly used code of answer to question mentioned in beginning.

Final note: I am on Windows 7/10, using TeXWorks, TeXlive instalation, new to TeX; also, creating new "compilation tool," lualatex with added argument -shell-escape works, but causes still too much clicking for my taste.

Thank you very much for any replies and advices, regards Tomáš

2

1 Answer 1

6

It depends on the sequencing of what you are trying to run

NOTE there should be a : after both the engine: {and each directive: yes}

i.e. Is for a first and third OR just one pass ?

% Here the first pass is to  compile with shell support
% arara: lualatex: { shell: true, interaction: nonstopmode }
%
% arara: somethingElse: { options: ['whatever'] }
%
% Here is a final pass where we want to include a synctex file
% arara: lualatex: { synctex: true, shell: true }

 
 

% If it is just for one combined pass, we could add 
% arara: lualatex: { synctex: true, shell: true, interaction: nonstopmode }

The value true is the same as yes , so this should work just the same

% arara: lualatex: { synctex: yes, shell: yes, interaction: nonstopmode }

as far as I know the synctex: option does not support -1 but there should be little harm for clarity in using 1 in place of yes so you should be able to use

% arara: lualatex: { synctex: 1, shell: yes, interaction: nonstopmode }  
4
  • Hello and thank you for your reply. Answered my question, but in my case I actually had to use: % arara: lualatex: { shell: true } % arara: makeglossaries % arara: lualatex: { synctex: true, shell: true } The option "interaction" wasnt defined in my "ruleset" in .yaml ; I cant edit it, since its in my work and I am not allowed to access that data (at least right now). Thanks again, Thomas PS: Should I use synctex option always while I am compiling LuaLaTeX with arara? Commented Mar 25, 2019 at 9:04
  • The nonstopmode is generally optional it skips interaction on errors so may or may not be desirable in a batch mode however on a good run it should not be needed :-) the use of synctex on the last run is also related to going back for more edits so if the batch is done fit for publication / use by others then there is no point keeping that feature :-)
    – user170109
    Commented Mar 25, 2019 at 11:52
  • just a related question concerning "synctex: yes = synctex: true" - there is also the option "synctex: on" - does that differ from yes/true?
    – user168390
    Commented Jul 17, 2019 at 10:24
  • Taking this one more step, I tried to add a file name parameter to the arara list (as part of the [pdflatex -shell-escape] tikzexternalize instructions): arara: pdflatex: { synctex: true, shell: true, files: <$projecttitle>.tex }, but the code errors out. Any thoughts on what is wrong with the files: syntax? Commented Mar 4, 2022 at 20:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .