I would like to use the sigconf style from acmart.cls.

I have already downloaded the acmart.cls file into the latex folder, run texhash and copied a minimal .layout file:

#% Do not delete the line below; configure depends on this

# Input general definitions
Input stdclass.inc

Then reconfigured Lyx (version and chosen the new document class in the document settings.

However, upon PDF creation, it chooses the wrong option for my purpose, probably acmlarge.

How can I tell Lyx to choose option sigconf instead?

  • the first line of your tex file should be \documentclass[format=sigconf]{acmart} that declaration should then be followed by everything else for support on acmart you can follow the guidance at acm.org/publications/authors/submissions the key to a good working class is that you installed the package with either tex live manager or MiKTeX-console they then configure the files into the correct locations for the class file to operate as directed by you and the editor – KJO Mar 23 at 12:34
  • 1
    @KJO This is a LyX question not a pure LaTeX question so although your comment is helpful for LaTeX it doesn't address the question at hand. – Alan Munn Mar 23 at 12:50
  • @AlanMunn OK have changed the comment to an answer i.e. change the class format – KJO Mar 23 at 13:03

The correct class file is essential to control the pdf output so when you start an acmart document using lyx it adds this first line by default

\documentclass[english,format=acmsmall, review=false, screen=true]{acmart}

enter image description here

Thus you desire to change the format so replace acmsmall with sigconf

  • Looks good! Any idea why the abstract won't show in the PDF? – Radio Controlled Mar 23 at 13:23
  • sorry don't use LyX so haven't a clue what it does with the files, as a seperate question you could post the relavent lines of tex code and someone may see if there is a conflict for something like abstract in LyX it helps non lyx users to see a mini screen shot of either the result or work in progress or the settings gui to understand why LyX settings are different to plain lines of code – KJO Mar 23 at 13:30
  • Yeah no worries, I only use lyx for the first versions. The final publication I finish in tex. I'll just enter a section as an abstract to get approximate space consumption. – Radio Controlled Mar 23 at 13:48
  • 1
    looking at the abstract section it needs a valid coded cut and paste from the website so would need a suitable clipboard chunk of output . However it looks like the abstact has to be manually cut and pasted too where it say abstract here ! – KJO Mar 23 at 13:54
  • 1
    P.S. re your query about abstract I was looking at another issue and reminded your problem could be due to placement of abstract in that template see tex.stackexchange.com/questions/385029/… – KJO Mar 24 at 2:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.