7

In the cleveref package document, it is clearly stated that the noabbrev option prevents the names of the references to be abbreviated. For instance instead of "Fig. 1", I'll get "Figure 1". However, when I use the option like this:

\usepackage[noabbrev]{cleveref}

I get the following error:

Unknown option 'noabbrev' for package 'cleveref'.

How can I solve the problem? Is there any versioning issue? I am using MacTeX-2011.

Edit: Here is the lines from log file related to the problem:

(/usr/local/texlive/2011/texmf-dist/tex/latex/cleveref/cleveref.sty
Package: cleveref 2011/03/22 v0.17.9 Intelligent cross-referencing
Package cleveref Info: `hyperref' support loaded on input line 2157.
LaTeX Info: Redefining \cref on input line 2157.
LaTeX Info: Redefining \Cref on input line 2157.
LaTeX Info: Redefining \crefrange on input line 2157.
LaTeX Info: Redefining \Crefrange on input line 2157.
...
3
  • Please indicate which version of cleveref is used by your TeX distribution. You can find this information by searching the .log file for the line that mentions that the cleveref package is being loaded. In all likelihood, your TeX distribution contains an obsolete version of the package.
    – Mico
    Commented Mar 15, 2012 at 12:47
  • @Mico: Thanks, that's a useful point. See my edit, please.
    – Helium
    Commented Mar 15, 2012 at 17:56
  • Thanks buddies, I just updated the package and it works now.
    – Helium
    Commented Mar 15, 2012 at 18:16

1 Answer 1

12

cleveref is at version 0.18.4 at the moment. The noabbrev option was introduced in version 0.18 (from December 2011, announcement at comp.text.tex), so this is most likely a versioning issue.

EDIT: According to your log file, you are using cleveref 0.17.9, so you need to switch to a more recent version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .